aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-02-03 12:21:22 -0800
committerSaul Wold <sgw@linux.intel.com>2012-02-07 14:37:15 -0800
commit25016d158af927e0c9e70c3df4674f53fa54fec8 (patch)
treeb6e273f4cb6a9adc4e4996d6b3318ba617ed080d /meta/recipes-devtools/python/python
parent7eae02f47a08587cf5be3d39df0184cf346cbaea (diff)
downloadopenembedded-core-25016d158af927e0c9e70c3df4674f53fa54fec8.tar.gz
python: Fix build failure of python-elementtree on x86_64
The problem is due to mixing of headers from host system thusly corrected in setup.py by checkinng if we are cross compiling Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-devtools/python/python')
-rw-r--r--meta/recipes-devtools/python/python/host_include_contamination.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python/host_include_contamination.patch b/meta/recipes-devtools/python/python/host_include_contamination.patch
new file mode 100644
index 0000000000..62cb8b16da
--- /dev/null
+++ b/meta/recipes-devtools/python/python/host_include_contamination.patch
@@ -0,0 +1,27 @@
+when building python for qemux86-64 on ubuntu 11.10/64bit
+it gropes into host includes and then mixes them with cross
+includes and as a result some modules fail to compile and link
+one of the modules is python-elementtree which is then not
+found during image creation
+
+Proble is that setup.py tries to add native includes that newer
+ubuntu has introduced for multiarch support. But that should
+only happen for native builds and not cross building python
+so we add a check here.
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Upstream-Status: Pending
+
+Index: Python-2.7.2/setup.py
+===================================================================
+--- Python-2.7.2.orig/setup.py 2012-02-03 12:10:42.307057756 -0800
++++ Python-2.7.2/setup.py 2012-02-03 12:11:12.363059210 -0800
+@@ -360,6 +360,8 @@
+ # https://wiki.ubuntu.com/MultiarchSpec
+ if not find_executable('dpkg-architecture'):
+ return
++ if os.environ.get('CROSS_COMPILE') is not None:
++ return
+ tmpfile = os.path.join(self.build_temp, 'multiarch')
+ if not os.path.exists(self.build_temp):
+ os.makedirs(self.build_temp)