aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pygobject_3.24.1.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2017-06-15 17:49:14 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-28 15:51:57 +0100
commit2468534985c43326513a03aa88521c7f467fc347 (patch)
treef3c08a7c678dbf9be7d1385e3c63839c42fa42b1 /meta/recipes-devtools/python/python3-pygobject_3.24.1.bb
parent91ee8dc0cfdd1ea96176723c2412b801f107b752 (diff)
downloadopenembedded-core-2468534985c43326513a03aa88521c7f467fc347.tar.gz
python3-pygobject: update to 3.24.1
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python3-pygobject_3.24.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pygobject_3.24.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pygobject_3.24.1.bb b/meta/recipes-devtools/python/python3-pygobject_3.24.1.bb
new file mode 100644
index 0000000000..5795ae31da
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pygobject_3.24.1.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Python GObject bindings"
+SECTION = "devel/python"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
+
+inherit autotools pkgconfig gnomebase distutils3-base gobject-introspection upstream-version-is-even
+
+DEPENDS += "gnome-common-native python3 glib-2.0"
+
+SRCNAME="pygobject"
+SRC_URI = " \
+ http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz \
+ file://0001-configure.ac-add-sysroot-path-to-GI_DATADIR-don-t-se.patch \
+"
+
+SRC_URI[md5sum] = "69a843311d0f0385dff376e11a2d83d2"
+SRC_URI[sha256sum] = "a628a95aa0909e13fb08230b1b98fc48adef10b220932f76d62f6821b3fdbffd"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+
+PACKAGECONFIG ??= "${@bb.utils.contains_any('DISTRO_FEATURES', [ 'directfb', 'wayland', 'x11' ], 'cairo', '', d)}"
+
+# python3-pycairo is checked on configuration -> DEPENDS
+# we don't link against python3-pycairo -> RDEPENDS
+PACKAGECONFIG[cairo] = "--enable-cairo,--disable-cairo,cairo python3-pycairo, python3-pycairo"
+
+RDEPENDS_${PN} += "python3-setuptools python3-importlib"
+
+BBCLASSEXTEND = "native"
+PACKAGECONFIG_class-native = ""