summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-dtc_1.7.0.bb
diff options
context:
space:
mode:
authorTrevor Gamblin <tgamblin@baylibre.com>2023-08-17 15:02:38 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-08-24 13:34:35 +0100
commit55208224f492af0ad929555ffc9b95ff1d301c5f (patch)
treea24fdc1297f1bc8602df871efcad905b10d5880c /meta/recipes-devtools/python/python3-dtc_1.7.0.bb
parent843f82a246a535c353e08072f252d1dc78217872 (diff)
downloadopenembedded-core-55208224f492af0ad929555ffc9b95ff1d301c5f.tar.gz
python3-dtc: upgrade 1.6.1 -> 1.7.0
Changelog: https://kernel.googlesource.com/pub/scm/utils/dtc/dtc/+log/039a99414e778332d8f9c04cbd3072e1dcc62798 Remove custom PV from the recipe since the relevant functionality is in 1.7.0: [tgamblin@megalith dtc]$ git tag --contains c001fc01a43e7a06447c06ea3d50bd60641322b8 v1.7.0 Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-dtc_1.7.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-dtc_1.7.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-dtc_1.7.0.bb b/meta/recipes-devtools/python/python3-dtc_1.7.0.bb
new file mode 100644
index 0000000000..85e48d4694
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-dtc_1.7.0.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Python Library for the Device Tree Compiler"
+HOMEPAGE = "https://devicetree.org/"
+DESCRIPTION = "A python library for the Device Tree Compiler, a tool used to manipulate Device Tree files which contain a data structure for describing hardware."
+SECTION = "bootloader"
+LICENSE = "GPL-2.0-only | BSD-2-Clause"
+
+DEPENDS = "flex-native bison-native swig-native python3-setuptools-scm-native libyaml dtc"
+
+SRC_URI = "git://git.kernel.org/pub/scm/utils/dtc/dtc.git;branch=master \
+ file://0001-Revert-libfdt-overlay-make-overlay_get_target-public.patch \
+ "
+
+UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
+
+LIC_FILES_CHKSUM = "file://pylibfdt/libfdt.i;beginline=1;endline=6;md5=afda088c974174a29108c8d80b5dce90"
+
+SRCREV = "039a99414e778332d8f9c04cbd3072e1dcc62798"
+
+S = "${WORKDIR}/git"
+
+PYPA_WHEEL = "${S}/dist/libfdt-1.6.2*.whl"
+
+inherit setuptools3 pkgconfig
+
+BBCLASSEXTEND = "native nativesdk"