aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-setuptools_36.2.7.bb
diff options
context:
space:
mode:
authorJose Lamego <jose.a.lamego@linux.intel.com>2017-08-09 15:01:04 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-16 00:01:43 +0100
commit147d9260eb79edfdf7a91fb8bc3d915f141dc685 (patch)
tree32661ed772db1eaf05b2ab3b75afd3ef444e3b21 /meta/recipes-devtools/python/python-setuptools_36.2.7.bb
parent652e515cbdf0f6314b63ec52b9fcac42299c3d60 (diff)
downloadopenembedded-core-147d9260eb79edfdf7a91fb8bc3d915f141dc685.tar.gz
python*-setuptools: update to 36.2.7
Both python-setuptools and python3-setuptools must be updated to latest stable release. These changes were tested on qemu with core-image-minimal Signed-off-by: Jose Lamego <jose.a.lamego@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-setuptools_36.2.7.bb')
-rw-r--r--meta/recipes-devtools/python/python-setuptools_36.2.7.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-setuptools_36.2.7.bb b/meta/recipes-devtools/python/python-setuptools_36.2.7.bb
new file mode 100644
index 0000000000..526474c7ea
--- /dev/null
+++ b/meta/recipes-devtools/python/python-setuptools_36.2.7.bb
@@ -0,0 +1,38 @@
+require python-setuptools.inc
+
+PROVIDES = "python-distribute"
+
+DEPENDS += "python"
+DEPENDS_class-native += "python-native"
+
+inherit distutils
+
+DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${PYTHON_SITEPACKAGES_DIR}"
+
+RDEPENDS_${PN} = "\
+ python-stringold \
+ python-email \
+ python-shell \
+ python-distutils \
+ python-compression \
+ python-pkgutil \
+ python-plistlib \
+ python-numbers \
+ python-html \
+ python-netserver \
+ python-ctypes \
+ python-subprocess \
+ python-unittest \
+ python-compile \
+"
+
+RDEPENDS_${PN}_class-native = "\
+ python-distutils \
+ python-compression \
+"
+
+RREPLACES_${PN} = "python-distribute"
+RPROVIDES_${PN} = "python-distribute"
+RCONFLICTS_${PN} = "python-distribute"
+
+BBCLASSEXTEND = "native nativesdk"