aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-pygtk_2.17.0.bb
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2010-10-01 16:39:49 +0100
committerJoshua Lock <josh@linux.intel.com>2010-10-01 16:47:38 +0100
commitdf07008f56676b2fe4dd64e565303d21a6770ed6 (patch)
treec709a79502a24c345e07dd21e2edc5eeae63b7e8 /meta/recipes-devtools/python/python-pygtk_2.17.0.bb
parentce5e891d51eac0ed2615294c7bd25eedd5650de2 (diff)
downloadopenembedded-core-df07008f56676b2fe4dd64e565303d21a6770ed6.tar.gz
python-pygtk: Use correct paths at build time
Fix the paths in configure.ac to use the target libraries and generators for building pygtk. Fix taken from OE. Thanks to Gary Thomas for providing a first stab at this. Signed-off-by: Joshua Lock <josh@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python-pygtk_2.17.0.bb')
-rw-r--r--meta/recipes-devtools/python/python-pygtk_2.17.0.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python-pygtk_2.17.0.bb b/meta/recipes-devtools/python/python-pygtk_2.17.0.bb
index ef63b51038..3dcfd64a9d 100644
--- a/meta/recipes-devtools/python/python-pygtk_2.17.0.bb
+++ b/meta/recipes-devtools/python/python-pygtk_2.17.0.bb
@@ -6,7 +6,7 @@ RDEPENDS = "python-shell python-pycairo python-pygobject"
PROVIDES = "python-pygtk2"
SRCNAME = "pygtk"
LICENSE = "LGPL"
-PR = "ml8.2"
+PR = "ml8.3"
SRC_URI = "ftp://ftp.gnome.org/pub/gnome/sources/pygtk/2.17/${SRCNAME}-${PV}.tar.bz2 \
file://fix-gtkunixprint.patch \
@@ -21,6 +21,14 @@ inherit autotools pkgconfig distutils-base
do_configure_prepend() {
install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
+ sed -i \
+ -e s:'`$PKG_CONFIG --variable defsdir pygobject-2.0`':\"${STAGING_DATADIR}/pygobject/2.0/defs\":g \
+ -e s:'`$PKG_CONFIG --variable=pygtkincludedir pygobject-2.0`':\"${STAGING_INCDIR}/pygtk-2.0\":g \
+ -e s:'`$PKG_CONFIG --variable=datadir pygobject-2.0`':\"${STAGING_DATADIR}\":g \
+ -e s:'`$PKG_CONFIG --variable codegendir pygobject-2.0`':\"${STAGING_DATADIR}/pygobject/2.0/codegen\":g \
+ -e s:'`$PKG_CONFIG --variable=fixxref pygobject-2.0`':\"${STAGING_DATADIR}/pygobject/xsl/fixxref.py\":g \
+ ${S}/configure.ac
+ sed -i 's:tests docs:tests:' Makefile.am
}
# dirty fix #1: remove dependency on python-pygobject-dev