aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/pseudo
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2011-01-14 14:37:59 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-01-18 17:54:52 +0000
commita72f0aaabe16c3b08f277695ebf6b6c052fde0ae (patch)
treebe2c20271030961370cc9f27f187ac564f969ab3 /meta/recipes-devtools/pseudo
parent26396016aedeeebd42cfa833b3ae642e61154dc2 (diff)
downloadopenembedded-core-a72f0aaabe16c3b08f277695ebf6b6c052fde0ae.tar.gz
Workaround issue with latest version of pseudo.
The latest version of pseudo occasionally caches on an execvp. This should resolve the issue. Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Diffstat (limited to 'meta/recipes-devtools/pseudo')
-rw-r--r--meta/recipes-devtools/pseudo/pseudo/pseudo-exec-crash.patch20
-rw-r--r--meta/recipes-devtools/pseudo/pseudo_git.bb1
2 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-devtools/pseudo/pseudo/pseudo-exec-crash.patch b/meta/recipes-devtools/pseudo/pseudo/pseudo-exec-crash.patch
new file mode 100644
index 0000000000..a73ed64804
--- /dev/null
+++ b/meta/recipes-devtools/pseudo/pseudo/pseudo-exec-crash.patch
@@ -0,0 +1,20 @@
+The cached data values were being collected when an OP_EXEC call was made.
+This is incorrect as the values are only for logging purposes. It's believed
+this caused an occasional crash in certain instances.
+
+Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
+
+diff --git a/pseudo.c b/pseudo.c
+index efee436..62f28f3 100644
+--- a/pseudo.c
++++ b/pseudo.c
+@@ -1021,7 +1021,8 @@ pseudo_op(pseudo_msg_t *msg, const char *program, const char *tag) {
+ if (msg->op != OP_MAY_UNLINK &&
+ msg->op != OP_DID_UNLINK &&
+ msg->op != OP_CANCEL_UNLINK &&
+- msg->op != OP_UNLINK) {
++ msg->op != OP_UNLINK &&
++ msg->op != OP_EXEC ) {
+ cache_msg = *msg;
+
+ if (path_by_ino) {
diff --git a/meta/recipes-devtools/pseudo/pseudo_git.bb b/meta/recipes-devtools/pseudo/pseudo_git.bb
index df73696a7e..6645033c3e 100644
--- a/meta/recipes-devtools/pseudo/pseudo_git.bb
+++ b/meta/recipes-devtools/pseudo/pseudo_git.bb
@@ -10,6 +10,7 @@ PR = "r16"
SRC_URI = "git://github.com/wrpseudo/pseudo.git;protocol=git \
file://static_sqlite.patch \
+ file://pseudo-exec-crash.patch \
"
FILES_${PN} = "${libdir}/libpseudo.so ${bindir}/* ${localstatedir}/pseudo"