aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/pseudo
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2011-01-24 19:23:14 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-01-25 12:25:45 +0000
commit3b3711672861a82bf73d9ecbc20d07a8bb4aff2d (patch)
tree4391f6926ebd1d191df912d880a2b0f03eec2592 /meta/recipes-devtools/pseudo
parentc0e1272d1526484f1921f3dd14ca042798d530d9 (diff)
downloadopenembedded-core-3b3711672861a82bf73d9ecbc20d07a8bb4aff2d.tar.gz
pseudo: Revert msg cache changes
The message cache code in pseudo seems to be causing problems. So we have finally decided to revert that optimization. (The revert is in the upstream pseudo.) Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Diffstat (limited to 'meta/recipes-devtools/pseudo')
-rw-r--r--meta/recipes-devtools/pseudo/pseudo/pseudo-exec-crash.patch20
-rw-r--r--meta/recipes-devtools/pseudo/pseudo_git.bb3
2 files changed, 1 insertions, 22 deletions
diff --git a/meta/recipes-devtools/pseudo/pseudo/pseudo-exec-crash.patch b/meta/recipes-devtools/pseudo/pseudo/pseudo-exec-crash.patch
deleted file mode 100644
index a73ed64804..0000000000
--- a/meta/recipes-devtools/pseudo/pseudo/pseudo-exec-crash.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-The cached data values were being collected when an OP_EXEC call was made.
-This is incorrect as the values are only for logging purposes. It's believed
-this caused an occasional crash in certain instances.
-
-Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
-
-diff --git a/pseudo.c b/pseudo.c
-index efee436..62f28f3 100644
---- a/pseudo.c
-+++ b/pseudo.c
-@@ -1021,7 +1021,8 @@ pseudo_op(pseudo_msg_t *msg, const char *program, const char *tag) {
- if (msg->op != OP_MAY_UNLINK &&
- msg->op != OP_DID_UNLINK &&
- msg->op != OP_CANCEL_UNLINK &&
-- msg->op != OP_UNLINK) {
-+ msg->op != OP_UNLINK &&
-+ msg->op != OP_EXEC ) {
- cache_msg = *msg;
-
- if (path_by_ino) {
diff --git a/meta/recipes-devtools/pseudo/pseudo_git.bb b/meta/recipes-devtools/pseudo/pseudo_git.bb
index 6645033c3e..4e94df7e8c 100644
--- a/meta/recipes-devtools/pseudo/pseudo_git.bb
+++ b/meta/recipes-devtools/pseudo/pseudo_git.bb
@@ -6,11 +6,10 @@ LICENSE = "LGPL2.1"
DEPENDS = "sqlite3"
PV = "0.0+git${SRCPV}"
-PR = "r16"
+PR = "r17"
SRC_URI = "git://github.com/wrpseudo/pseudo.git;protocol=git \
file://static_sqlite.patch \
- file://pseudo-exec-crash.patch \
"
FILES_${PN} = "${libdir}/libpseudo.so ${bindir}/* ${localstatedir}/pseudo"