summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/pkgconfig
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2012-10-27 16:48:17 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-11-02 16:15:30 +0000
commitbb67ddeb2eed3e25c626a279ef53a7e8c7bfe6f2 (patch)
treea5cd401b043e80311db7497dec8c791b873aab2e /meta/recipes-devtools/pkgconfig
parent528b4ab831c7b0bc1412318d29e2b7f9cf711d57 (diff)
downloadopenembedded-core-bb67ddeb2eed3e25c626a279ef53a7e8c7bfe6f2.tar.gz
openembedded-core-bb67ddeb2eed3e25c626a279ef53a7e8c7bfe6f2.tar.bz2
openembedded-core-bb67ddeb2eed3e25c626a279ef53a7e8c7bfe6f2.zip
recipes-devtools: replace virtclass-native(sdk) with class-native(sdk)
The overrides virtclass-native and virtclass-nativesdk are deprecated, which should be replaced by class-native and class-nativesdk. [YOCTO #3297] Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/pkgconfig')
-rw-r--r--meta/recipes-devtools/pkgconfig/pkgconfig.inc8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-devtools/pkgconfig/pkgconfig.inc b/meta/recipes-devtools/pkgconfig/pkgconfig.inc
index 8a8320e043..83a9cdf80a 100644
--- a/meta/recipes-devtools/pkgconfig/pkgconfig.inc
+++ b/meta/recipes-devtools/pkgconfig/pkgconfig.inc
@@ -9,8 +9,8 @@ LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
DEPENDS = "glib-2.0 popt"
-DEPENDS_virtclass-native = ""
-DEPENDS_virtclass-nativesdk = ""
+DEPENDS_class-native = ""
+DEPENDS_class-nativesdk = ""
SRC_URI = "http://pkgconfig.freedesktop.org/releases/pkg-config-${PV}.tar.gz \
file://autofoo.patch \
@@ -22,8 +22,8 @@ S = "${WORKDIR}/pkg-config-${PV}/"
inherit autotools
EXTRA_OECONF = "--with-installed-glib --with-installed-popt --disable-legacy-scripts"
-EXTRA_OECONF_virtclass-native = "--disable-legacy-scripts"
-EXTRA_OECONF_virtclass-nativesdk = "--disable-legacy-scripts"
+EXTRA_OECONF_class-native = "--disable-legacy-scripts"
+EXTRA_OECONF_class-nativesdk = "--disable-legacy-scripts"
acpaths = "-I ."
do_configure_prepend () {