aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl
diff options
context:
space:
mode:
authorMatthew McClintock <msm@freescale.com>2012-07-05 14:18:35 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-09 16:58:18 +0100
commit2c3629a698e537c69c71039bc6172b3c0e617ff1 (patch)
tree5ca2ac29048f3411d90d0c4870be97fbdc6de21e /meta/recipes-devtools/perl
parent7cd54693363882854cd026ebe071e9f2e03d364e (diff)
downloadopenembedded-core-2c3629a698e537c69c71039bc6172b3c0e617ff1.tar.gz
libxml-parser-perl_2.41.bb: fix MakeMaker issues with using wrong CC/LD/etc
MakeMaker has a bug where it does not propagate CC/LD/etc information down to subproject it generates Makefiles for... this recipe has has an Expat subproject which has issues building if we are using sstate-cache and it will reference the old sysroots and be unable to build properly. There is an upstream MakeMaker bug for this issue but we can work around it by fixing up the Makefiles for now See: https://rt.cpan.org/Public/Bug/Display.html?id=28632 Signed-off-by: Matthew McClintock <msm@freescale.com>
Diffstat (limited to 'meta/recipes-devtools/perl')
-rw-r--r--meta/recipes-devtools/perl/libxml-parser-perl_2.41.bb11
1 files changed, 9 insertions, 2 deletions
diff --git a/meta/recipes-devtools/perl/libxml-parser-perl_2.41.bb b/meta/recipes-devtools/perl/libxml-parser-perl_2.41.bb
index be41578f08..33b4d83862 100644
--- a/meta/recipes-devtools/perl/libxml-parser-perl_2.41.bb
+++ b/meta/recipes-devtools/perl/libxml-parser-perl_2.41.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://README;beginline=2;endline=6;md5=c8767d7516229f07b26e
DEPENDS += "expat expat-native"
-PR = "r2"
+PR = "r3"
SRC_URI = "http://www.cpan.org/modules/by-module/XML/XML-Parser-${PV}.tar.gz"
SRC_URI[md5sum] = "c320d2ffa459e6cdc6f9f59c1185855e"
@@ -13,10 +13,17 @@ SRC_URI[sha256sum] = "b48197cd2265a26c5f016489f11a7b450d8833cb8b3d6a46ee15975740
S = "${WORKDIR}/XML-Parser-${PV}"
-EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
+EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR} CC=${CC} LD=${LD} FULL_AR=${AR}"
inherit cpan
+# fix up sub MakeMaker project as arguments don't get propagated though
+# see https://rt.cpan.org/Public/Bug/Display.html?id=28632
+do_configure_append() {
+ sed 's:--sysroot=.*\(\s\|$\):--sysroot=${STAGING_DIR_TARGET} :g' -i Makefile Expat/Makefile
+ sed 's:^FULL_AR = .*:FULL_AR = ${AR}:g' -i Expat/Makefile
+}
+
do_compile() {
export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
cpan_do_compile