aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl
diff options
context:
space:
mode:
authorVenkata ramana gollamudi <ramana.gollamudi@huawei.com>2012-04-17 09:04:15 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-17 12:24:32 +0100
commit16542d982d86d42d3189d47a8180f0f71646a9ca (patch)
treea0900c819a8bb52428b823d21f83adae6973e10f /meta/recipes-devtools/perl
parentc084759d7f69b751e1ed3ef79d686389d867f248 (diff)
downloadopenembedded-core-16542d982d86d42d3189d47a8180f0f71646a9ca.tar.gz
perl: fix re-execution of compile task
After building perl package, re-execution of compile task recursively substitutes the path, making it an invalid path. Fixed to prevent recursive substitution. Similar case as [Yocto #2194] Signed-off-by: Venkata Ramana Gollamudi <ramana.gollamudi@huawei.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl')
-rw-r--r--meta/recipes-devtools/perl/perl_5.14.2.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.14.2.bb b/meta/recipes-devtools/perl/perl_5.14.2.bb
index ecb2262796..809fc72d33 100644
--- a/meta/recipes-devtools/perl/perl_5.14.2.bb
+++ b/meta/recipes-devtools/perl/perl_5.14.2.bb
@@ -174,8 +174,9 @@ do_configure() {
}
do_compile() {
- sed -i -e 's|/usr/include|${STAGING_INCDIR}|g' ext/Errno/Errno_pm.PL
- sed -i -e 's|/usr/include|${STAGING_INCDIR}|g' cpan/Compress-Raw-Zlib/config.in
+ # Fix to avoid recursive substitution of path
+ sed -i -e "s|\([ \"\']\+\)/usr/include|\1${STAGING_INCDIR}|g" ext/Errno/Errno_pm.PL
+ sed -i -e "s|\([ \"\']\+\)/usr/include|\1${STAGING_INCDIR}|g" cpan/Compress-Raw-Zlib/config.in
sed -i -e 's|/usr/lib|""|g' cpan/Compress-Raw-Zlib/config.in
sed -i -e 's|SYSROOTLIB|${STAGING_LIBDIR}|g' cpan/ExtUtils-MakeMaker/lib/ExtUtils/Liblist/Kid.pm