aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl_5.8.8.bb
diff options
context:
space:
mode:
authorKevin Tian <kevin.tian@intel.com>2011-01-05 14:50:33 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-01-07 11:09:48 +0000
commit16fa641f991a0ea44833b7c133c5863bf1476889 (patch)
tree8ee348f4be94d333e39057794f649467cf484ee5 /meta/recipes-devtools/perl/perl_5.8.8.bb
parent97789a160ad21ccc614f976fa5e2b306d816aabf (diff)
downloadopenembedded-core-16fa641f991a0ea44833b7c133c5863bf1476889.tar.gz
perl: use ${CCLD} instead of its own LD definition
perl explicitly assigns LD to a bogus value: oe_runmake perl LD="${TARGET_SYS}-gcc" which breaks sstate-based build when toolchain is not generated locally, due to lacking of --sysroot option. Use ${CCLD} instead to make this relocatable. Signed-off-by: Kevin Tian <kevin.tian@intel.com>
Diffstat (limited to 'meta/recipes-devtools/perl/perl_5.8.8.bb')
-rw-r--r--meta/recipes-devtools/perl/perl_5.8.8.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.8.8.bb b/meta/recipes-devtools/perl/perl_5.8.8.bb
index 8e2f0c0af7..5cd4d4fe2f 100644
--- a/meta/recipes-devtools/perl/perl_5.8.8.bb
+++ b/meta/recipes-devtools/perl/perl_5.8.8.bb
@@ -11,7 +11,7 @@ PRIORITY = "optional"
# We need gnugrep (for -I)
DEPENDS = "virtual/db perl-native grep-native"
DEPENDS += "gdbm"
-PR = "r21"
+PR = "r22"
# Major part of version
PVM = "5.8"
@@ -114,7 +114,7 @@ do_compile() {
sed -i -e 's|/usr/include|${STAGING_INCDIR}|g' ext/Errno/Errno_pm.PL
fi
cd Cross
- oe_runmake perl LD="${TARGET_SYS}-gcc"
+ oe_runmake perl LD="${CCLD}"
}
do_install() {