aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl_5.14.2.bb
diff options
context:
space:
mode:
authorKang Kai <kai.kang@windriver.com>2012-12-18 18:16:28 +0800
committerSaul Wold <sgw@linux.intel.com>2013-01-04 22:01:20 -0800
commit96fb96ddd00881947875518df832fa74faec8a45 (patch)
treec01e5c2bc26fc307c2d236f2b7a7d70de8d79509 /meta/recipes-devtools/perl/perl_5.14.2.bb
parentc76ae248334606d10ab730b1b2e9f626ff3c5809 (diff)
downloadopenembedded-core-96fb96ddd00881947875518df832fa74faec8a45.tar.gz
perl: add sub-package perl-tests
In perl source code, run "make test" will run perl test cases. Put these cases into a seprated sub-package then we can run the perl test on target. Add following module to nonxs_ext to install extra modules that required by perl test cases: CPAN/Meta CPAN/Meta/YAML Dumpvalue Env File/CheckTree HTTP/Tiny I18N/Collate JSON/PP Perl/OSType Version/Requirements Commands to run test: cd /opt/perl-tests/t && ./TEST [Yocto 3296] Signed-off-by: Kang Kai <kai.kang@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/perl/perl_5.14.2.bb')
-rw-r--r--meta/recipes-devtools/perl/perl_5.14.2.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.14.2.bb b/meta/recipes-devtools/perl/perl_5.14.2.bb
index 4dac5ceb86..8cff7f58cf 100644
--- a/meta/recipes-devtools/perl/perl_5.14.2.bb
+++ b/meta/recipes-devtools/perl/perl_5.14.2.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
# We need gnugrep (for -I)
DEPENDS = "virtual/db grep-native"
DEPENDS += "gdbm zlib"
-PR = "r15"
+PR = "r16"
# 5.10.1 has Module::Build built-in
PROVIDES += "libmodule-build-perl"
@@ -319,6 +319,7 @@ RPROVIDES_perl-lib = "perl-lib"
require perl-rdepends_${PV}.inc
require perl-rprovides.inc
require perl-rprovides_${PV}.inc
+include perl-tests.inc
SSTATE_SCAN_FILES += "*.pm *.pod *.h *.pl *.sh"