aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/liburi-perl_1.60.bb
diff options
context:
space:
mode:
authorKang Kai <kai.kang@windriver.com>2012-07-25 17:42:44 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-26 14:45:04 +0100
commit987c57c9a19706067f1590e0f647557a870f769c (patch)
treea839b17dbbba8899ff176ed991a49def599feadc /meta/recipes-devtools/perl/liburi-perl_1.60.bb
parent6b3c2aa5a32d7d21f9ac760dc7aa18829c03a875 (diff)
downloadopenembedded-core-987c57c9a19706067f1590e0f647557a870f769c.tar.gz
liburi-perl: update to 1.60
Update to 1.60 Signed-off-by: Kang Kai <kai.kang@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/perl/liburi-perl_1.60.bb')
-rw-r--r--meta/recipes-devtools/perl/liburi-perl_1.60.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/liburi-perl_1.60.bb b/meta/recipes-devtools/perl/liburi-perl_1.60.bb
new file mode 100644
index 0000000000..4eb98b21a2
--- /dev/null
+++ b/meta/recipes-devtools/perl/liburi-perl_1.60.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "This package contains the URI.pm module with friends. \
+The module implements the URI class. URI objects can be used to access \
+and manipulate the various components that make up these strings."
+
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+PR = "r0"
+
+LIC_FILES_CHKSUM = "file://README;beginline=26;endline=30;md5=6c33ae5c87fd1c4897714e122dd9c23d"
+
+DEPENDS += "perl"
+
+SRC_URI = "http://www.cpan.org/authors/id/G/GA/GAAS/URI-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "70f739be8ce28b8baba7c5920ffee4dc"
+SRC_URI[sha256sum] = "1f92d3dc64acb8845e9917c945e22b9a5275aeb9ff924eb7873c3b7a5c0d2377"
+
+S = "${WORKDIR}/URI-${PV}"
+
+EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
+
+inherit cpan
+
+do_compile() {
+ export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
+ cpan_do_compile
+}