aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2017-04-27 17:28:09 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-05-18 13:24:07 +0100
commitbb5718b631151cff840bcfa171ad4f8326c2132e (patch)
tree702c34fd0c493bff6263a24fc6fd2a2de8b0431e /meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
parent4af605ae6f5ca763c65b3dca10b7ffb60f5ffa2e (diff)
downloadopenembedded-core-bb5718b631151cff840bcfa171ad4f8326c2132e.tar.gz
opkg-utils: move to Python 3
The scripts were fixed to be compatible with py3 some time ago, but the shebang continued to refer to python 2.x. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/opkg-utils/opkg-utils_git.bb')
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils_git.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb b/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
index 9deea0f5e5..2460a26324 100644
--- a/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
@@ -4,13 +4,14 @@ SECTION = "base"
HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
- file://opkg.py;beginline=1;endline=18;md5=15917491ad6bf7acc666ca5f7cc1e083"
+ file://opkg.py;beginline=2;endline=18;md5=63ce9e6bcc445181cd9e4baf4b4ccc35"
PROVIDES += "${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'virtual/update-alternatives', '', d)}"
SRCREV = "1a708fd73d10c2b7677dd4cc4e017746ebbb9166"
PV = "0.3.4+git${SRCPV}"
SRC_URI = "git://git.yoctoproject.org/opkg-utils \
+ file://0001-Switch-all-scripts-to-use-Python-3.x.patch \
"
SRC_URI_append_class-native = " file://tar_ignore_error.patch"
@@ -18,7 +19,7 @@ S = "${WORKDIR}/git"
TARGET_CC_ARCH += "${LDFLAGS}"
-PYTHONRDEPS = "python python-shell python-io python-math python-crypt python-logging python-fcntl python-subprocess python-pickle python-compression python-textutils python-stringold"
+PYTHONRDEPS = "python3 python3-shell python3-io python3-math python3-crypt python3-logging python3-fcntl python3-subprocess python3-pickle python3-compression python3-textutils python3-stringold"
PYTHONRDEPS_class-native = ""
PACKAGECONFIG = "python update-alternatives"