aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opensp
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-09-03 20:52:12 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-09-05 17:53:02 +0100
commitce236234831ebc05ffdf1e0a368692ac2818a388 (patch)
tree87e0721830257151c682fd3c1752796d6e26dfb0 /meta/recipes-devtools/opensp
parent9106e2922ba5972e3b87436372a12c2e04e9eb65 (diff)
downloadopenembedded-core-ce236234831ebc05ffdf1e0a368692ac2818a388.tar.gz
opensp: Fix sstate relocation issue
[YOCTO #1440] This fixes a problem where the native nsgmls has a path hard coded into it, therefor add a wrapper to set the environment with the correct paths for catalog files. Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/opensp')
-rw-r--r--meta/recipes-devtools/opensp/opensp_1.5.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/meta/recipes-devtools/opensp/opensp_1.5.bb b/meta/recipes-devtools/opensp/opensp_1.5.bb
index a402d11c72..0269c87be4 100644
--- a/meta/recipes-devtools/opensp/opensp_1.5.bb
+++ b/meta/recipes-devtools/opensp/opensp_1.5.bb
@@ -5,7 +5,7 @@ SECTION = "libs"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=641ff1e4511f0a87044ad42f87cb1045"
-PR = "r1"
+PR = "r2"
# At -Os it encounters calls to some inline functions which are then
# not found in any other objects with gcc 4.5
@@ -42,6 +42,13 @@ do_install_append() {
ln -sf osx sgml2xml
}
+do_install_append_virtclass-native() {
+ for util in nsgmls sgmlnorm spam spcat spent sx; do
+ create_wrapper ${D}/${bindir}/$util \
+ SGML_CATALOG_FILES=${sysconfdir}/sgml/catalog
+ done
+}
+
FILES_${PN} += "${datadir}/OpenSP/"
BBCLASSEXTEND = "native"