aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/m4
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/recipes-devtools/m4
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadopenembedded-core-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/m4')
-rw-r--r--meta/recipes-devtools/m4/m4-native_1.4.13.bb12
-rw-r--r--meta/recipes-devtools/m4/m4/ac_config_links.patch28
-rw-r--r--meta/recipes-devtools/m4/m4/make.patch41
-rw-r--r--meta/recipes-devtools/m4/m4_1.4.13.bb9
4 files changed, 90 insertions, 0 deletions
diff --git a/meta/recipes-devtools/m4/m4-native_1.4.13.bb b/meta/recipes-devtools/m4/m4-native_1.4.13.bb
new file mode 100644
index 0000000000..fa871b38ae
--- /dev/null
+++ b/meta/recipes-devtools/m4/m4-native_1.4.13.bb
@@ -0,0 +1,12 @@
+require m4_${PV}.bb
+inherit native
+
+INHIBIT_AUTOTOOLS_DEPS = "1"
+DEPENDS += "gnu-config-native"
+
+do_configure() {
+ install -m 0644 ${STAGING_DATADIR}/gnu-config/config.sub .
+ install -m 0644 ${STAGING_DATADIR}/gnu-config/config.guess .
+ oe_runconf
+}
+
diff --git a/meta/recipes-devtools/m4/m4/ac_config_links.patch b/meta/recipes-devtools/m4/m4/ac_config_links.patch
new file mode 100644
index 0000000000..22103876e3
--- /dev/null
+++ b/meta/recipes-devtools/m4/m4/ac_config_links.patch
@@ -0,0 +1,28 @@
+This patch fixes a build problem for m4-native experienced on Ubuntu 9.10,
+where autoconf/automake (AC_CONFIG_LINKS) ends up making GNUmakefile a
+symlink to itself.
+
+The patch comments out ac_config_links directly in configure,
+as autoreconf is not actually run for m4-native.
+
+I believe it should be safe, as GNUmakefile is actually unpacked from
+source, and what we want is to is to not touch it.
+
+Tested on x86_64_linux (Ubuntu 8.04 and 9.10).
+
+2009-11-10 Esben Haabendal <eha@doredevelopment.dk>
+
+diff -urN m4-1.4.13.orig/configure m4-1.4.13/configure
+--- m4-1.4.13.orig/configure 2009-11-10 10:54:00.301707097 +0100
++++ m4-1.4.13/configure 2009-11-10 10:54:17.314206379 +0100
+@@ -14860,8 +14860,8 @@
+ # only, it does not matter if we skip the link with older autoconf.
+ # Automake 1.10.1 and earlier try to remove GNUmakefile in non-VPATH
+ # builds, so use a shell variable to bypass this.
+- GNUmakefile=GNUmakefile
+- ac_config_links="$ac_config_links $GNUmakefile:$GNUmakefile"
++ # GNUmakefile=GNUmakefile
++ # ac_config_links="$ac_config_links $GNUmakefile:$GNUmakefile"
+
+
+
diff --git a/meta/recipes-devtools/m4/m4/make.patch b/meta/recipes-devtools/m4/m4/make.patch
new file mode 100644
index 0000000000..3577b0b7db
--- /dev/null
+++ b/meta/recipes-devtools/m4/m4/make.patch
@@ -0,0 +1,41 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- m4-1.4.2/doc/Makefile.in~make
++++ m4-1.4.2/doc/Makefile.in
+@@ -57,9 +57,9 @@
+ date > $(srcdir)/stamp-vti
+
+ install: all
+- $(srcdir)/../mkinstalldirs $(infodir)
++ $(srcdir)/../mkinstalldirs $(DESTDIR)$(infodir)
+ cd $(srcdir) && for file in m4.info*; do \
+- $(INSTALL_DATA) $$file $(infodir)/$$file; \
++ $(INSTALL_DATA) $$file $(DESTDIR)$(infodir)/$$file; \
+ done
+
+ uninstall:
+--- m4-1.4.2/src/Makefile.in~make
++++ m4-1.4.2/src/Makefile.in
+@@ -35,7 +35,7 @@
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+ transform = @program_transform_name@
+-bindir = $(exec_prefix)/bin
++bindir = @bindir@
+
+ COMPILE = $(CC) -c $(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS)
+ LINK = $(CC) $(LDFLAGS) -o $@
+@@ -84,8 +84,8 @@
+ $(LINK) ansi2knr.o $(LIBS)
+
+ install: all
+- $(srcdir)/../mkinstalldirs $(bindir)
+- $(INSTALL_PROGRAM) m4 $(bindir)/`echo m4 | sed '$(transform)'`
++ $(srcdir)/../mkinstalldirs $(DESTDIR)$(bindir)
++ $(INSTALL_PROGRAM) m4 $(DESTDIR)$(bindir)/`echo m4 | sed '$(transform)'`
+
+ uninstall:
+ rm -f $(bindir)/`echo m4 | sed '$(transform)'`
diff --git a/meta/recipes-devtools/m4/m4_1.4.13.bb b/meta/recipes-devtools/m4/m4_1.4.13.bb
new file mode 100644
index 0000000000..32d153ea12
--- /dev/null
+++ b/meta/recipes-devtools/m4/m4_1.4.13.bb
@@ -0,0 +1,9 @@
+DESCRIPTION = "GNU m4 is an implementation of the traditional Unix macro processor."
+LICENSE = "GPLv3"
+SRC_URI = "${GNU_MIRROR}/m4/m4-${PV}.tar.gz \
+ file://ac_config_links.patch;patch=1"
+PR = "r2"
+
+inherit autotools
+
+EXTRA_OEMAKE += "'infodir=${infodir}'"