aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/libtool
diff options
context:
space:
mode:
authorJason Wessel <jason.wessel@windriver.com>2013-02-12 13:36:44 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-13 16:48:26 +0000
commit605e4484840e70c64acddb4aa1a3c9fec4078d9d (patch)
treeeed7485349544dee1043d6cd82fb810b3a8a5ab6 /meta/recipes-devtools/libtool
parentf2a0784f368fa8a766aae4242a0c187759b35393 (diff)
downloadopenembedded-core-605e4484840e70c64acddb4aa1a3c9fec4078d9d.tar.gz
libtool-native_2.4.2.bb: Always use /bin/sed for SED
If you never use sstate and always build everything from scratch you will never see this problem. However, if you use sstate and build directories that last a long time eventually you can end up with the scenario where libtool gets a hard coded path in it for sed, and sed may not exist. The reason you don't see this problem to often if you generally build from scratch is that libtool builds before sed and will pickup the host's /bin/sed. The way to reproduce the issue is: bitbake some_image bitbake -c cleansstate libtool-native bitbake sed-native bitbake libtool-native bitbake -c clean sed-native bitbake ANY_PACKAGE_THAT_USES_LIBTOOL_NATIVE In my case I used modphp, which doesn't exist in the oe-core. You will end up with a strange looking error like: | make[1]: *** [buckets/apr_buckets_alloc.lo] Error 1 | /opt/build/bitbake_build/tmp/sysroots/x86_64-linux/usr/bin/x86_64-linux-libtool: line 981: /opt/build/bitbake_build/tmp/sysroots/x86_64-linux//bin/sed: No such file or directory The solution is to always use /bin/sed for libtool-native. Signed-off-by: Jason Wessel <jason.wessel@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/libtool')
-rw-r--r--meta/recipes-devtools/libtool/libtool-native_2.4.2.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-devtools/libtool/libtool-native_2.4.2.bb b/meta/recipes-devtools/libtool/libtool-native_2.4.2.bb
index f12e6a15ea..18188ef7f3 100644
--- a/meta/recipes-devtools/libtool/libtool-native_2.4.2.bb
+++ b/meta/recipes-devtools/libtool/libtool-native_2.4.2.bb
@@ -2,12 +2,13 @@ require libtool-${PV}.inc
DEPENDS = ""
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
SRC_URI += "file://prefix.patch"
inherit native
EXTRA_OECONF = " --with-libtool-sysroot=${STAGING_DIR_NATIVE}"
+CACHED_CONFIGUREVARS += "ac_cv_path_SED=/bin/sed"
do_configure_prepend () {
# Remove any existing libtool m4 since old stale versions would break