aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/json-c
diff options
context:
space:
mode:
authorJack Mitchell <jmitchell@cbnl.com>2013-11-18 16:14:25 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-11-20 14:03:04 +0000
commit533c1db22eddaaaea7d58d1fc75d608b9ba8122a (patch)
tree1508e547d214a8ff0e1b56a5fa63c1ce23c74359 /meta/recipes-devtools/json-c
parent9ae204660814a8dc50b67d6c35b872dfa78c17e1 (diff)
downloadopenembedded-core-533c1db22eddaaaea7d58d1fc75d608b9ba8122a.tar.gz
libjson: update to 0.11 and rename to json-c
libjson is now known as json-c. Config.status is removed as it breaks seperate build dir builds. Built without parallel make as it fails, official word is not to bother trying. Signed-off-by: Jack Mitchell <jmitchell@cbnl.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/json-c')
-rw-r--r--meta/recipes-devtools/json-c/json-c_0.11.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/json-c/json-c_0.11.bb b/meta/recipes-devtools/json-c/json-c_0.11.bb
new file mode 100644
index 0000000000..831f281b69
--- /dev/null
+++ b/meta/recipes-devtools/json-c/json-c_0.11.bb
@@ -0,0 +1,20 @@
+SUMMARY = "JSON-C implements a reference counting object model that allows you to easily construct JSON objects in C"
+HOMEPAGE = "https://github.com/json-c/json-c/wiki"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=de54b60fbbc35123ba193fea8ee216f2"
+
+SRC_URI = "https://s3.amazonaws.com/json-c_releases/releases/${BP}.tar.gz"
+
+SRC_URI[md5sum] = "aa02367d2f7a830bf1e3376f77881e98"
+SRC_URI[sha256sum] = "28dfc65145dc0d4df1dfe7701ac173c4e5f9347176c8983edbfac9149494448c"
+
+RPROVIDES_${PN} = "libjson"
+
+PARALLEL_MAKE = ""
+
+inherit autotools
+
+do_configure_prepend() {
+ # Clean up autoconf cruft that should not be in the tarball
+ rm ${S}/config.status
+}