aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/guile
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-07-04 12:30:07 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-17 10:42:34 +0100
commit497d8d82b8e7e04a457a7fdd689c657903218c0d (patch)
tree7d1d9d9a3fbb6439ad2b1614809f275229cdee15 /meta/recipes-devtools/guile
parentba9e4ee09f39c427c0d1ba2d0d4c4f59029e4bea (diff)
downloadopenembedded-core-497d8d82b8e7e04a457a7fdd689c657903218c0d.tar.gz
grub,guile,cpio,tar,wget: Fix gnulib for absense of gets in eglibc
eglibc 2.16 does not export gets anymore Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/guile')
-rw-r--r--meta/recipes-devtools/guile/files/remove-gets.patch23
-rw-r--r--meta/recipes-devtools/guile/guile_2.0.5.bb3
2 files changed, 25 insertions, 1 deletions
diff --git a/meta/recipes-devtools/guile/files/remove-gets.patch b/meta/recipes-devtools/guile/files/remove-gets.patch
new file mode 100644
index 0000000000..6d3605f106
--- /dev/null
+++ b/meta/recipes-devtools/guile/files/remove-gets.patch
@@ -0,0 +1,23 @@
+ISO C11 removes the specification of gets() from the C language, eglibc 2.16+ removed it
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Pending
+Index: guile-2.0.5/lib/stdio.in.h
+===================================================================
+--- guile-2.0.5.orig/lib/stdio.in.h 2012-01-24 03:06:06.000000000 -0800
++++ guile-2.0.5/lib/stdio.in.h 2012-07-04 12:28:15.617108481 -0700
+@@ -711,11 +711,13 @@
+ _GL_CXXALIAS_SYS (gets, char *, (char *s));
+ # undef gets
+ # endif
++# if defined gets
+ _GL_CXXALIASWARN (gets);
+ /* It is very rare that the developer ever has full control of stdin,
+ so any use of gets warrants an unconditional warning. Assume it is
+ always declared, since it is required by C89. */
+ _GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
++# endif
+ #endif
+
+
diff --git a/meta/recipes-devtools/guile/guile_2.0.5.bb b/meta/recipes-devtools/guile/guile_2.0.5.bb
index cf222a6f47..fc94a412a1 100644
--- a/meta/recipes-devtools/guile/guile_2.0.5.bb
+++ b/meta/recipes-devtools/guile/guile_2.0.5.bb
@@ -20,6 +20,7 @@ SRC_URI = "${GNU_MIRROR}/guile/guile-${PV}.tar.gz \
file://guile_2.0.5_fix_sed_error.patch \
file://guile_2.0.5_disable_goops_optimizations.patch \
file://guile_2.0.5_fix_cross_compilation.patch \
+ file://remove-gets.patch \
"
# file://debian/0001-Change-guile-to-guile-X.Y-for-info-pages.patch
@@ -28,7 +29,7 @@ SRC_URI = "${GNU_MIRROR}/guile/guile-${PV}.tar.gz \
SRC_URI[md5sum] = "bcf70d54b44c99cb9acd3f63c5486b4b"
SRC_URI[sha256sum] = "2a026ea6cdbc51ca71bcd9787839debfa45ac5db1e26dc00b30ca9b128b10956"
-PR = "r1"
+PR = "r2"
inherit autotools gettext
BBCLASSEXTEND = "native"