aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/e2fsprogs/e2fsprogs/mkdir.patch
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2016-01-13 17:37:28 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-17 11:32:16 +0000
commita1f235ad736d322bb50eb4a4293b6b2f4e5200aa (patch)
tree03b4c525f754c89c3e307823f37e6a944726375c /meta/recipes-devtools/e2fsprogs/e2fsprogs/mkdir.patch
parent8a474057d86b3ebf6271656d6b9adf384ea9ad6d (diff)
downloadopenembedded-core-a1f235ad736d322bb50eb4a4293b6b2f4e5200aa.tar.gz
e2fsprogs: 1.42.9 -> 1.43 (master)
Upgrade to 1.43 (master) to make "mke2fs -d" support xattr, so that the layer which requires xattr such as meta-selinux can populate images easily. * Remove the following patches since they are alredy in the source. 0001-e2fsprogs-fix-cross-compilation-problem.patch 0001-libext2fs-fix-potential-buffer-overflow-in-closefs.patch 0001-mke2fs-add-the-ability-to-copy-files-from-a-given-di.patch 0002-misc-create_inode.c-copy-files-recursively.patch 0003-misc-create_inode.c-create-special-file.patch 0004-misc-create_inode.c-create-symlink.patch 0005-misc-create_inode.c-copy-regular-file.patch 0006-misc-create_inode.c-create-directory.patch 0007-misc-create_inode.c-set-owner-mode-time-for-the-inod.patch 0008-mke2fs.c-add-an-option-d-root-directory.patch 0009-misc-create_inode.c-handle-hardlinks.patch 0010-debugfs-use-the-functions-in-misc-create_inode.c.patch 0011-mke2fs.8.in-update-the-manual-for-the-d-option.patch 0012-Fix-musl-build-failures.patch CVE-2015-0247.patch copy-in-create-hardlinks-with-the-correct-directory-.patch fix-icache.patch misc-mke2fs.c-return-error-when-failed-to-populate-fs.patch * Remove cache_inode.patch since it is not needed any more * Updated mkdir.patch and ptest.patch * Add --enable-libblkid to EXTRA_OECONF since libblkid is not created by default. * Time of core-image-sato-sdk do_rootfs: - Before upgrade real 3m18.508s user 7m42.088s sys 1m1.984s - After upgrade real 3m21.552s user 7m38.496s sys 1m0.644s The are nearly the same * The "fsck -f" shows the image is OK, and also can boot. [YOCTO #8622] Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta/recipes-devtools/e2fsprogs/e2fsprogs/mkdir.patch')
-rw-r--r--meta/recipes-devtools/e2fsprogs/e2fsprogs/mkdir.patch32
1 files changed, 10 insertions, 22 deletions
diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs/mkdir.patch b/meta/recipes-devtools/e2fsprogs/e2fsprogs/mkdir.patch
index aa7a2981b4..2a3aeff613 100644
--- a/meta/recipes-devtools/e2fsprogs/e2fsprogs/mkdir.patch
+++ b/meta/recipes-devtools/e2fsprogs/e2fsprogs/mkdir.patch
@@ -2,29 +2,17 @@ Upstream-Status: Inappropriate [configuration]
Signed-off-by: Mei Lei <lei.mei@intel.com>
-Index: e2fsprogs-1.41.5/po/Makefile.in.in
-===================================================================
---- e2fsprogs-1.41.5.orig/po/Makefile.in.in 2009-02-14 13:49:08.000000000 +0000
-+++ e2fsprogs-1.41.5/po/Makefile.in.in 2009-08-19 17:52:31.000000000 +0100
-@@ -30,7 +30,7 @@
- INSTALL = @INSTALL@
- INSTALL_DATA = @INSTALL_DATA@
- MKINSTALLDIRS = @MKINSTALLDIRS@
--mkinstalldirs = $(SHELL) $(MKINSTALLDIRS)
-+mkinstalldirs = $(MKINSTALLDIRS)
-
- GMSGFMT = @GMSGFMT@
- MSGFMT = @MSGFMT@
-Index: e2fsprogs-1.41.5/configure.in
-===================================================================
---- e2fsprogs-1.41.5.orig/configure.in 2009-08-19 17:53:50.000000000 +0100
-+++ e2fsprogs-1.41.5/configure.in 2009-08-19 17:48:38.000000000 +0100
-@@ -970,6 +970,8 @@
+diff --git a/configure.ac b/configure.ac
+index c1fe224..f5ac628 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1374,7 +1374,8 @@ if test -n "$WITH_DIET_LIBC" ; then
+ INCLUDES="$INCLUDES -D_REENTRANT"
fi
- AC_SUBST(BUILD_CFLAGS)
- AC_SUBST(BUILD_LDFLAGS)
+ AC_SUBST(INCLUDES)
+-AM_MKINSTALLDIRS
+MKINSTALLDIRS="mkdir -p"
+AC_SUBST(MKINSTALLDIRS)
dnl
- dnl Make our output files, being sure that we create the some miscellaneous
- dnl directories
+ dnl Build CFLAGS
+ dnl