aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/automake
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>2012-09-22 17:18:08 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-24 11:17:36 +0100
commita87db6f8dea71cbb7ead9285ff8af0e28cf75604 (patch)
tree05973be4aa5448c9a92c17719bd523e3a50ae2d2 /meta/recipes-devtools/automake
parent8cf6f87bd753e1c84a018ddb92a97eed7bd79a28 (diff)
downloadopenembedded-core-a87db6f8dea71cbb7ead9285ff8af0e28cf75604.tar.gz
autotools: Remove special handling for autoconf* and automake*
For reasons that are now shrouded in obscurity, autotools.bbclass has long contained a special heuristic to avoid attempting to run autoreconf when building autoconf or automake themselves. However, the wildcard test against PN which is used there is problematic when trying to build another package whose name happens to start with "autoconf", and in any case it is silly to do this test at runtime for every package. The individual recipes for autoconf and automake can just as easily suppress the behaviour that they don't want by providing a custom do_configure() method which just runs configure. Signed-off-by: Phil Blundell <pb@pbcl.net> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/automake')
-rw-r--r--meta/recipes-devtools/automake/automake.inc4
-rw-r--r--meta/recipes-devtools/automake/automake_1.12.3.bb2
2 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-devtools/automake/automake.inc b/meta/recipes-devtools/automake/automake.inc
index 370cacadfc..ae743cc58a 100644
--- a/meta/recipes-devtools/automake/automake.inc
+++ b/meta/recipes-devtools/automake/automake.inc
@@ -9,6 +9,10 @@ SRC_URI = "${GNU_MIRROR}/automake/automake-${PV}.tar.gz"
inherit autotools
+do_configure() {
+ oe_runconf
+}
+
export AUTOMAKE = "${@bb.which('automake', d.getVar('PATH', True))}"
FILES_${PN} += "${datadir}/automake* ${datadir}/aclocal*"
diff --git a/meta/recipes-devtools/automake/automake_1.12.3.bb b/meta/recipes-devtools/automake/automake_1.12.3.bb
index 25069d72b5..af99dfa2c5 100644
--- a/meta/recipes-devtools/automake/automake_1.12.3.bb
+++ b/meta/recipes-devtools/automake/automake_1.12.3.bb
@@ -42,7 +42,7 @@ SRC_URI += "${PATHFIXPATCH} \
SRC_URI[md5sum] = "d2af8484de94cdee16d89c50aaa1c729"
SRC_URI[sha256sum] = "095ffaa3ac887d1eb3511bf13d7f1fc9ec0503c6a06aeae05c93730cdda9a5a0"
-PR = "r0"
+PR = "r1"
do_install () {
oe_runmake 'DESTDIR=${D}' install