aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/automake
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-17 10:08:53 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-05 12:35:42 +0000
commit0f485bfd6fc82a109b9da629e464fca1e90faec3 (patch)
tree1606c51c99e069d303a0210fcef518b5fdc482cf /meta/recipes-devtools/automake
parent0c97fd9d721cea9786e89a557418649ef4576cfd (diff)
downloadopenembedded-core-0f485bfd6fc82a109b9da629e464fca1e90faec3.tar.gz
native.bbclass: Fix variable remapping coverage
When looking for RDEPENDS to process, bitbake iterates through PACKAGES *and* PN. Since native.bbclass sets PACKAGES to be empty, its pointless remapping the list of PACKAGES since this does nothing. There is a problem since *_${PN} are used by bitbake but not remapped by the native.bbclass class extension code. This changes the code to remap _${PN} in both expanded and unexpanded forms. As a result of this, various surprising dependencies are uncovered and the patch rectifies those. These are real bugs since they're injecting unneeded (unremapped) dependencies into the dependency chain. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/automake')
-rw-r--r--meta/recipes-devtools/automake/automake_1.11.2.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-devtools/automake/automake_1.11.2.bb b/meta/recipes-devtools/automake/automake_1.11.2.bb
index b455edfe6f..0a65f24fbe 100644
--- a/meta/recipes-devtools/automake/automake_1.11.2.bb
+++ b/meta/recipes-devtools/automake/automake_1.11.2.bb
@@ -3,7 +3,7 @@ LICENSE="GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
DEPENDS_virtclass-native = "autoconf-native"
-RDEPENDS_automake += "\
+RDEPENDS_${PN} += "\
autoconf \
perl \
perl-module-bytes \
@@ -27,7 +27,8 @@ RDEPENDS_automake += "\
perl-module-text-parsewords \
perl-module-vars "
-RDEPENDS_automake-native = "autoconf-native perl-native-runtime"
+RDEPENDS_${PN}_virtclass-native = "autoconf-native perl-native-runtime"
+RDEPENDS_${PN}_virtclass-nativesdk = "autoconf-nativesdk"
PATHFIXPATCH = "file://path_prog_fixes.patch"
PATHFIXPATCH_virtclass-native = ""