summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorAlejandro Enedino Hernandez Samaniego <alejandr@xilinx.com>2018-04-27 13:21:20 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-06-15 08:54:19 +0100
commit9f0570351a7b0877aa50efff5fe9a9ef368cb38f (patch)
treedb6d5c3ad8d220202b45783edc6f371a2976d1fa /meta/recipes-core
parent6f7ef4f6049fa8f2a8e17abfcf53ccbc22394088 (diff)
downloadopenembedded-core-9f0570351a7b0877aa50efff5fe9a9ef368cb38f.tar.gz
tclibc-newlib: Adds a new TCLIBC variant to build with newlib as C library
This patch adds the posibility to build using TCLIBC=newlib. It allows users to build baremetal applications with the use of a C library. Newlib is a lightweight C library meant to be used on embedded systems, it is meant to be easily portable for new platforms and to provide basic functionality on them, by design, it provides stubs for some of these core functions declared as weak, so they can be built correctly and then linked against some other library which provides specifics about the platform being used if need be, libgloss takes care of these in some cases, but it can also be extended, this patch also allows the user to easily add other libraries to it by adding them to NEWLIB_EXTENDED for this specific reason. Signed-off-by: Alejandro Enedino Hernandez Samaniego <alejandr@xilinx.com>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/newlib/newlib_3.0.0.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-core/newlib/newlib_3.0.0.bb b/meta/recipes-core/newlib/newlib_3.0.0.bb
index 3380576b83..09238fe006 100644
--- a/meta/recipes-core/newlib/newlib_3.0.0.bb
+++ b/meta/recipes-core/newlib/newlib_3.0.0.bb
@@ -14,3 +14,6 @@ do_install_append() {
# Remove original directory
rmdir ${D}${prefix}/${TARGET_SYS}
}
+
+# No rpm package is actually created but -dev depends on it, avoid dnf error
+RDEPENDS_${PN}-dev_libc-newlib = ""