summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorDennis Lan <dennis.yxun@gmail.com>2012-06-28 14:36:50 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-29 13:09:51 +0100
commit6a013236d362874c661aa5f15b948aac32177181 (patch)
treec5e596bca5991958f28c3e5769c493b091ca2b82 /meta/recipes-core
parente052ab9ac0f464ae4c7054a9af6663a0213d4192 (diff)
downloadopenembedded-core-6a013236d362874c661aa5f15b948aac32177181.tar.gz
eglibc: support mipsel little endian, filter out -march=mips32
Quote for eglibc source: for mips eglibc now builds syscall tables for all abi's so we make sure that we choose right march option which is compatible with o32,n32 and n64 abi's e.g. -march=mips32 is not compatible with n32 and n64 therefore we filter it out in such case -march=from-abi which will be mips1 when using o32 and mips3 when using n32/n64 Signed-off-by: Dennis Lan <dennis.yxun@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.15.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-core/eglibc/eglibc_2.15.bb b/meta/recipes-core/eglibc/eglibc_2.15.bb
index adf1048209..7dd9810f35 100644
--- a/meta/recipes-core/eglibc/eglibc_2.15.bb
+++ b/meta/recipes-core/eglibc/eglibc_2.15.bb
@@ -101,6 +101,7 @@ do_patch_append() {
# mips1 when using o32 and mips3 when using n32/n64
TUNE_CCARGS_mips := "${@oe_filter_out('-march=mips32', '${TUNE_CCARGS}', d)}"
+TUNE_CCARGS_mipsel := "${@oe_filter_out('-march=mips32', '${TUNE_CCARGS}', d)}"
# We need to ensure that all of the i386 and x86_64 headers are identical
# to support the multilib case. We do this by copying headers from x86_64