summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2023-01-27 13:40:55 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-01-29 10:50:44 +0000
commit54ae53ef3e4ad51fc9a01155588b62f29c994742 (patch)
tree4a41889cd9047f1c0d3bcc50bf2d51e861621795 /meta/recipes-core
parent10e140d98790ce28b440b8e8697a4311658fe4df (diff)
downloadopenembedded-core-54ae53ef3e4ad51fc9a01155588b62f29c994742.tar.gz
Revert "cve-update-db-native: show IP on failure"
The bug this was intended to find has been resolved, so we don't need this extra noise in the logs. This reverts commit bd1edfa3d5b1c24cd1192620f7085ee1df03e1af. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/meta/cve-update-db-native.bb5
1 files changed, 1 insertions, 4 deletions
diff --git a/meta/recipes-core/meta/cve-update-db-native.bb b/meta/recipes-core/meta/cve-update-db-native.bb
index e042e67b09..079f062f79 100644
--- a/meta/recipes-core/meta/cve-update-db-native.bb
+++ b/meta/recipes-core/meta/cve-update-db-native.bb
@@ -130,10 +130,7 @@ def update_db_file(db_tmp_file, d):
response = urllib.request.urlopen(meta_url, timeout=cve_socket_timeout)
except urllib.error.URLError as e:
cve_f.write('Warning: CVE db update error, Unable to fetch CVE data.\n\n')
- bb.warn("Failed to fetch CVE data (%s)" % e)
- import socket
- result = socket.getaddrinfo("nvd.nist.gov", 443, proto=socket.IPPROTO_TCP)
- bb.warn("Host IPs are %s" % (", ".join(t[4][0] for t in result)))
+ bb.warn("Failed to fetch CVE data (%s)" % e.reason)
return False
if response: