aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorJason Wessel <jason.wessel@windriver.com>2017-12-05 09:51:16 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-06 10:11:42 +0000
commit89456f911425c3e7f65e8b9202b8d02775129923 (patch)
tree693a9b0f21538b412b45726842ac83a5e7f6336e /meta/recipes-core
parentd831b1cbff2901f10f79bb43c839839f73c428a3 (diff)
downloadopenembedded-core-89456f911425c3e7f65e8b9202b8d02775129923.tar.gz
ovmf: Fix build failure for PARALLEL_MAKE with no space
The ovmf package fails to build if you use a PARALLEL_MAKE flag without a space in it. If you put the following in local.conf for example: PARALLEL_MAKE = "-j4" The build will fail with as follows: | build.exe: error: Option -n only allows one instance in command line! | WARNING: /opt/build/ovmf/git-r0/temp/run.do_compile.26080:1 exit 2 from '/opt/build/ovmf/git-r0/git/OvmfPkg/build.sh $PARALLEL_JOBS -a $OVMF_ARCH -b RELEASE -t ${FIXED_GCCVER}' | ERROR: Function failed: do_compile (log file is located at /opt/build/ovmf/git-r0/temp/log.do_compile.26080) The failure is because the build.sh expects a space. The simple work around is to fix the recipe to add some white space. The build.sh only cares that it gets at least one space between the arguments, the extra space if someone uses "-j 4" does not cause problems. Signed-off-by: Jason Wessel <jason.wessel@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> (cherry picked from commit cf7f4705e65a877cb4b3ac8872369c1b2e81a7be) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/ovmf/ovmf_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/ovmf/ovmf_git.bb b/meta/recipes-core/ovmf/ovmf_git.bb
index a98826210e..fa0d66291d 100644
--- a/meta/recipes-core/ovmf/ovmf_git.bb
+++ b/meta/recipes-core/ovmf/ovmf_git.bb
@@ -151,7 +151,7 @@ do_compile_class-native() {
do_compile_class-target() {
export LFLAGS="${LDFLAGS}"
- PARALLEL_JOBS="${@ '${PARALLEL_MAKE}'.replace('-j', '-n')}"
+ PARALLEL_JOBS="${@ '${PARALLEL_MAKE}'.replace('-j', '-n ')}"
OVMF_ARCH="X64"
if [ "${TARGET_ARCH}" != "x86_64" ] ; then
OVMF_ARCH="IA32"