aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-05-08 16:31:52 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-05-11 12:24:21 +0100
commitb8c0a4f6a319a7cf84530b891707a5887f3caaf4 (patch)
tree3a6cebab3ccc119c9d4ac1e58d5dd65fd814bfad /meta/recipes-core
parentaf00b6544f60e4d7581f9d9767f9d3f574392359 (diff)
downloadopenembedded-core-b8c0a4f6a319a7cf84530b891707a5887f3caaf4.tar.gz
util-linux: fix parallel build issure for PATHFILES
When compiling util-linux, it's possible to encounter the following error. /bin/sh: line 2:: misc-utils/uuidd.8.tmp: No such file or directory This is because that the misc-utils directory doesn't exist when trying to write to misc-utils/uuidd.8.tmp. When generating misc-utils/uuidd.8 (or anything in PATHFILES), its directory may not have been created yet. So we need to ensure the existence of the directory to avoid the compilation error. [YOCTO #6292] Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/util-linux/util-linux/util-linux-ensure-the-existence-of-directory-for-PAT.patch34
-rw-r--r--meta/recipes-core/util-linux/util-linux_2.24.2.bb1
2 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-core/util-linux/util-linux/util-linux-ensure-the-existence-of-directory-for-PAT.patch b/meta/recipes-core/util-linux/util-linux/util-linux-ensure-the-existence-of-directory-for-PAT.patch
new file mode 100644
index 0000000000..8f26451aa8
--- /dev/null
+++ b/meta/recipes-core/util-linux/util-linux/util-linux-ensure-the-existence-of-directory-for-PAT.patch
@@ -0,0 +1,34 @@
+Upstream-Status: Pending
+
+util-linux: ensure the existence of directory for PATHFILES
+
+When compiling util-linux, it's possible to encounter the following error.
+ /bin/sh: line 2:: misc-utils/uuidd.8.tmp: No such file or directory
+
+This is because that the misc-utils directory doesn't exist when trying to write to
+misc-utils/uuidd.8.tmp.
+
+When generating misc-utils/uuidd.8 (or anything in PATHFILES), its directory
+may not have been created yet. So we need to ensure the existence of the directory
+to avoid the compilation error.
+
+Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
+---
+ Makefile.am | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.am b/Makefile.am
+index 17f4c33..ca3dc0f 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -123,6 +123,7 @@ EXTRA_DIST += $(PATHFILES:=.in)
+
+ $(PATHFILES): Makefile
+ @ rm -f $@ $@.tmp
++ @ mkdir -p `dirname $@`
+ $(AM_V_GEN) srcdir=''; \
+ test -f ./$@.in || srcdir=$(srcdir)/; \
+ $(edit_cmd) $${srcdir}$@.in >$@.tmp
+--
+1.7.9.5
+
diff --git a/meta/recipes-core/util-linux/util-linux_2.24.2.bb b/meta/recipes-core/util-linux/util-linux_2.24.2.bb
index a2d74306a6..ed753e48b3 100644
--- a/meta/recipes-core/util-linux/util-linux_2.24.2.bb
+++ b/meta/recipes-core/util-linux/util-linux_2.24.2.bb
@@ -15,6 +15,7 @@ SRC_URI += "file://util-linux-ng-replace-siginterrupt.patch \
file://configure-sbindir.patch \
file://fix-configure.patch \
file://fix-parallel-build.patch \
+ file://util-linux-ensure-the-existence-of-directory-for-PAT.patch \
${OLDHOST} \
"