aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorTristan Van Berkom <tristan.vanberkom@codethink.co.uk>2016-04-25 16:36:26 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-29 19:33:24 +0100
commitae347b60406990c79fe1b89d23b175a48439274a (patch)
tree53c4c941fd3dd39fd4b9fc3c30d490cf8ecfc9dc /meta/recipes-core
parent64d69eba87394f0fbf564da7c37dc6b1d2e7ec1b (diff)
downloadopenembedded-core-ae347b60406990c79fe1b89d23b175a48439274a.tar.gz
cross-localedef-native_2.22.bb: Use autotools configure
Use the autotools default configure commands and just tell autotools where to run configure from. This fixes the build when running on an aarch64 host, which the prebuilt configure scripts with glibc 2.22 do not recognize. (From OE-Core rev: 33d4c758a5d71435437dde74556d32404d91342f) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster@mvista.com>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/glibc/cross-localedef-native_2.23.bb9
1 files changed, 4 insertions, 5 deletions
diff --git a/meta/recipes-core/glibc/cross-localedef-native_2.23.bb b/meta/recipes-core/glibc/cross-localedef-native_2.23.bb
index fa930fd480..a6795ed9b3 100644
--- a/meta/recipes-core/glibc/cross-localedef-native_2.23.bb
+++ b/meta/recipes-core/glibc/cross-localedef-native_2.23.bb
@@ -9,6 +9,10 @@ LIC_FILES_CHKSUM = "file://LICENSES;md5=e9a558e243b36d3209f380deb394b213 \
file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
+# Tell autotools that we're working in the localedef directory
+#
+AUTOTOOLS_SCRIPT_PATH = "${S}/localedef"
+
inherit native
inherit autotools
@@ -47,11 +51,6 @@ S = "${WORKDIR}/git"
EXTRA_OECONF = "--with-glibc=${S}"
CFLAGS += "-fgnu89-inline -std=gnu99 -DIS_IN\(x\)='0'"
-do_configure () {
- ${S}/localedef/configure ${EXTRA_OECONF}
-}
-
-
do_install() {
install -d ${D}${bindir}
install -m 0755 ${B}/localedef ${D}${bindir}/cross-localedef