aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorPetter Mabäcker <petter@technux.se>2014-05-12 15:55:38 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-05-13 19:24:03 +0100
commit57109e59abb7c6af029f452d06b46f47084cff11 (patch)
treeb0a5d2d8eb20d7f302031b97e4d7ffb4734880b7 /meta/recipes-core
parentae8711bc2952e96ac3434624548a3dbfd501ec7f (diff)
downloadopenembedded-core-57109e59abb7c6af029f452d06b46f47084cff11.tar.gz
eglibc: remove usage of FILESPATH
Fixes [YOCTO #4497] Usage of FILESPATH is discouraged, since it can make recipes harder to bbappend. Instead FILESEXTRAPATHS should be used to extend the path. If possible try to use any of the default FILESPATH dirs. Also remove superfluous comment and do minor indentation fix. Signed-off-by: Petter Mabäcker <petter@technux.se> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/eglibc/cross-localedef-native-2.19/fix_for_centos_5.8.patch (renamed from meta/recipes-core/eglibc/eglibc-2.19/fix_for_centos_5.8.patch)0
-rw-r--r--meta/recipes-core/eglibc/cross-localedef-native_2.19.bb3
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.19.bb4
-rw-r--r--meta/recipes-core/eglibc/ldconfig-native_2.12.1.bb2
4 files changed, 3 insertions, 6 deletions
diff --git a/meta/recipes-core/eglibc/eglibc-2.19/fix_for_centos_5.8.patch b/meta/recipes-core/eglibc/cross-localedef-native-2.19/fix_for_centos_5.8.patch
index 7618c99534..7618c99534 100644
--- a/meta/recipes-core/eglibc/eglibc-2.19/fix_for_centos_5.8.patch
+++ b/meta/recipes-core/eglibc/cross-localedef-native-2.19/fix_for_centos_5.8.patch
diff --git a/meta/recipes-core/eglibc/cross-localedef-native_2.19.bb b/meta/recipes-core/eglibc/cross-localedef-native_2.19.bb
index 3ce0e1d394..1c13eb824a 100644
--- a/meta/recipes-core/eglibc/cross-localedef-native_2.19.bb
+++ b/meta/recipes-core/eglibc/cross-localedef-native_2.19.bb
@@ -13,8 +13,7 @@ LIC_FILES_CHKSUM = "file://${LIC_DIR}/LICENSES;md5=e9a558e243b36d3209f380deb394b
inherit native
inherit autotools
-# pick up an eglibc patch
-FILESPATH = "${FILE_DIRNAME}/eglibc-${PV}"
+FILESEXTRAPATHS =. "${FILE_DIRNAME}/${P}:"
SRC_URI = "http://downloads.yoctoproject.org/releases/eglibc/eglibc-${PV}-svnr25243.tar.bz2 \
file://fix_for_centos_5.8.patch;patchdir=.. \
diff --git a/meta/recipes-core/eglibc/eglibc_2.19.bb b/meta/recipes-core/eglibc/eglibc_2.19.bb
index 8f096769ee..1ddce8224a 100644
--- a/meta/recipes-core/eglibc/eglibc_2.19.bb
+++ b/meta/recipes-core/eglibc/eglibc_2.19.bb
@@ -24,7 +24,7 @@ SRC_URI = "http://downloads.yoctoproject.org/releases/eglibc/eglibc-${PV}-svnr25
file://0001-R_ARM_TLS_DTPOFF32.patch \
file://0001-eglibc-run-libm-err-tab.pl-with-specific-dirs-in-S.patch \
file://fix-tibetian-locales.patch \
- file://ppce6500-32b_slow_ieee754_sqrt.patch \
+ file://ppce6500-32b_slow_ieee754_sqrt.patch \
"
SRC_URI[md5sum] = "197836c2ba42fb146e971222647198dd"
SRC_URI[sha256sum] = "baaa030531fc308f7820c46acdf8e1b2f8e3c1f40bcd28b6e440d1c95d170d4c"
@@ -49,8 +49,6 @@ TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}"
GLIBC_BROKEN_LOCALES = " _ER _ET so_ET yn_ER sid_ET tr_TR mn_MN gez_ET gez_ER bn_BD te_IN es_CR.ISO-8859-1"
-FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/eglibc-${PV}', '${FILE_DIRNAME}/eglibc', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
-
#
# For now, we will skip building of a gcc package if it is a uclibc one
# and our build is not a uclibc one, and we skip a glibc one if our build
diff --git a/meta/recipes-core/eglibc/ldconfig-native_2.12.1.bb b/meta/recipes-core/eglibc/ldconfig-native_2.12.1.bb
index 75ffbf615a..7c3463589b 100644
--- a/meta/recipes-core/eglibc/ldconfig-native_2.12.1.bb
+++ b/meta/recipes-core/eglibc/ldconfig-native_2.12.1.bb
@@ -16,7 +16,7 @@ SRC_URI = "file://ldconfig-native-2.12.1.tar.bz2 \
PR = "r2"
-FILESPATH = "${FILE_DIRNAME}/${PN}-${PV}/"
+FILESEXTRAPATHS =. "${FILE_DIRNAME}/${P}:"
inherit native