aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2015-03-19 10:50:19 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-03-21 09:42:12 +0000
commitcd20b3c009a9c1743f5cb054710214231e5dfcfc (patch)
treee9149edd4ad7800f76b7c8428b570129b625e5f4 /meta/recipes-core
parent680fc6e7c571f70cffa9799c21604e0719504591 (diff)
downloadopenembedded-core-cd20b3c009a9c1743f5cb054710214231e5dfcfc.tar.gz
busybox: libarchive: open_zipped() does not need to check extensions
Backport from busybox 1_22_stable branch: http://git.busybox.net/busybox/commit/?h=1_22_stable&id=28dd64a0e1a9cffcde7799f2849b66c0e16bb9cc Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/busybox/busybox/libarchive-open_zipped-does-not-need-to-check-extens.patch66
-rw-r--r--meta/recipes-core/busybox/busybox_1.22.1.bb1
2 files changed, 67 insertions, 0 deletions
diff --git a/meta/recipes-core/busybox/busybox/libarchive-open_zipped-does-not-need-to-check-extens.patch b/meta/recipes-core/busybox/busybox/libarchive-open_zipped-does-not-need-to-check-extens.patch
new file mode 100644
index 0000000000..cf914339cd
--- /dev/null
+++ b/meta/recipes-core/busybox/busybox/libarchive-open_zipped-does-not-need-to-check-extens.patch
@@ -0,0 +1,66 @@
+Upstream-status: Backport
+http://git.busybox.net/busybox/commit/?h=1_22_stable&id=28dd64a0e1a9cffcde7799f2849b66c0e16bb9cc
+
+From 28dd64a0e1a9cffcde7799f2849b66c0e16bb9cc Mon Sep 17 00:00:00 2001
+From: Denys Vlasenko <vda.linux@googlemail.com>
+Date: Fri, 10 Jan 2014 14:06:57 +0100
+Subject: [PATCH] libarchive: open_zipped() does not need to check extensions for e.g. gzip
+
+We only need to check for signature-less extensions,
+currently only .lzma. The rest can be happily autodetected.
+
+This fixes "zcat FILE_WITHOUT_GZ_EXT" case, among others.
+
+Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
+(cherry picked from commit 7c47b560a8fc97956dd8132bd7f1863d83c19866)
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ archival/libarchive/open_transformer.c | 23 +++++++++++------------
+ 1 file changed, 11 insertions(+), 12 deletions(-)
+
+diff --git a/archival/libarchive/open_transformer.c b/archival/libarchive/open_transformer.c
+index 4e98264..1aeba13 100644
+--- a/archival/libarchive/open_transformer.c
++++ b/archival/libarchive/open_transformer.c
+@@ -182,27 +182,26 @@ int FAST_FUNC setup_unzip_on_fd(int fd, int fail_if_not_detected)
+
+ int FAST_FUNC open_zipped(const char *fname)
+ {
+- char *sfx;
+ int fd;
+
+ fd = open(fname, O_RDONLY);
+ if (fd < 0)
+ return fd;
+
+- sfx = strrchr(fname, '.');
+- if (sfx) {
+- sfx++;
+- if (ENABLE_FEATURE_SEAMLESS_LZMA && strcmp(sfx, "lzma") == 0)
+- /* .lzma has no header/signature, just trust it */
++ if (ENABLE_FEATURE_SEAMLESS_LZMA) {
++ /* .lzma has no header/signature, can only detect it by extension */
++ char *sfx = strrchr(fname, '.');
++ if (sfx && strcmp(sfx+1, "lzma") == 0) {
+ open_transformer_with_sig(fd, unpack_lzma_stream, "unlzma");
+- else
+- if ((ENABLE_FEATURE_SEAMLESS_GZ && strcmp(sfx, "gz") == 0)
+- || (ENABLE_FEATURE_SEAMLESS_BZ2 && strcmp(sfx, "bz2") == 0)
+- || (ENABLE_FEATURE_SEAMLESS_XZ && strcmp(sfx, "xz") == 0)
+- ) {
+- setup_unzip_on_fd(fd, /*fail_if_not_detected:*/ 1);
++ return fd;
+ }
+ }
++ if ((ENABLE_FEATURE_SEAMLESS_GZ)
++ || (ENABLE_FEATURE_SEAMLESS_BZ2)
++ || (ENABLE_FEATURE_SEAMLESS_XZ)
++ ) {
++ setup_unzip_on_fd(fd, /*fail_if_not_detected:*/ 1);
++ }
+
+ return fd;
+ }
+--
+1.9.1
+
diff --git a/meta/recipes-core/busybox/busybox_1.22.1.bb b/meta/recipes-core/busybox/busybox_1.22.1.bb
index 3934278328..ae8eca70ff 100644
--- a/meta/recipes-core/busybox/busybox_1.22.1.bb
+++ b/meta/recipes-core/busybox/busybox_1.22.1.bb
@@ -34,6 +34,7 @@ SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
file://busybox-cross-menuconfig.patch \
file://CVE-2014-9645_busybox_reject_module_names_with_slashes.patch \
file://lzop-add-overflow-check.patch \
+ file://libarchive-open_zipped-does-not-need-to-check-extens.patch \
"
SRC_URI[tarball.md5sum] = "337d1a15ab1cb1d4ed423168b1eb7d7e"