aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorRoy.Li <rongqing.li@windriver.com>2013-09-04 06:56:41 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-09-14 08:23:39 +0100
commit8909b3b71b2ac792ae092b8f0a6c2ade28f6b73b (patch)
tree0f493afd5ea4c0d31476f0ff818cba1cad3a0356 /meta/recipes-core
parent8c2b5948d41d753982242cd86a1498ab4f1bb317 (diff)
downloadopenembedded-core-8909b3b71b2ac792ae092b8f0a6c2ade28f6b73b.tar.gz
systemd: link runlevel from systemctl
using update-alternatives to link runlevel from systemctl, as on Fedora 18 Signed-off-by: Roy.Li <rongqing.li@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/systemd/systemd_206.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-core/systemd/systemd_206.bb b/meta/recipes-core/systemd/systemd_206.bb
index 3f3a6c37d1..2d0ce9b062 100644
--- a/meta/recipes-core/systemd/systemd_206.bb
+++ b/meta/recipes-core/systemd/systemd_206.bb
@@ -262,7 +262,7 @@ python __anonymous() {
# TODO:
# u-a for runlevel and telinit
-ALTERNATIVE_${PN} = "init halt reboot shutdown poweroff"
+ALTERNATIVE_${PN} = "init halt reboot shutdown poweroff runlevel"
ALTERNATIVE_TARGET[init] = "${rootlibexecdir}/systemd/systemd"
ALTERNATIVE_LINK_NAME[init] = "${base_sbindir}/init"
@@ -284,6 +284,10 @@ ALTERNATIVE_TARGET[poweroff] = "${base_bindir}/systemctl"
ALTERNATIVE_LINK_NAME[poweroff] = "${base_sbindir}/poweroff"
ALTERNATIVE_PRIORITY[poweroff] ?= "300"
+ALTERNATIVE_TARGET[runlevel] = "${base_bindir}/systemctl"
+ALTERNATIVE_LINK_NAME[runlevel] = "${base_sbindir}/runlevel"
+ALTERNATIVE_PRIORITY[runlevel] ?= "300"
+
pkg_postinst_udev-hwdb () {
if test -n "$D"; then
${@qemu_run_binary(d, '$D', '${base_bindir}/udevadm')} hwdb --update \