summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/zlib
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/recipes-core/zlib
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadopenembedded-core-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/zlib')
-rw-r--r--meta/recipes-core/zlib/files/Makefile.am9
-rw-r--r--meta/recipes-core/zlib/files/configure.ac48
-rw-r--r--meta/recipes-core/zlib/zlib_1.2.5.bb22
3 files changed, 79 insertions, 0 deletions
diff --git a/meta/recipes-core/zlib/files/Makefile.am b/meta/recipes-core/zlib/files/Makefile.am
new file mode 100644
index 0000000000..b66d299d8f
--- /dev/null
+++ b/meta/recipes-core/zlib/files/Makefile.am
@@ -0,0 +1,9 @@
+lib_LTLIBRARIES = libz.la
+
+libz_la_SOURCES = adler32.c compress.c crc32.c gzlib.c gzclose.c gzread.c \
+ gzwrite.c uncompr.c deflate.c trees.c zutil.c inflate.c \
+ infback.c inftrees.c inffast.c
+
+libz_la_LDFLAGS = -version-number 1:2:5 --version-script zlib.map
+
+include_HEADERS = zconf.h zlib.h zlibdefs.h
diff --git a/meta/recipes-core/zlib/files/configure.ac b/meta/recipes-core/zlib/files/configure.ac
new file mode 100644
index 0000000000..4761b7ef28
--- /dev/null
+++ b/meta/recipes-core/zlib/files/configure.ac
@@ -0,0 +1,48 @@
+AC_INIT(zlib,1.2.5)
+AC_CONFIG_SRCDIR(adler32.c)
+AM_INIT_AUTOMAKE(zlibs,1.2.5)
+
+AC_PREREQ([2.59])
+
+AC_PROG_CC([gcc])
+AC_PROG_LIBTOOL
+
+AC_HEADER_STDC
+
+zlib_save_CPPFLAGS=$CPPFLAGS
+CPPFLAGS="$CPPFLAGS -D_LARGEFILE64_SOURCE"
+AC_CHECK_TYPES(off64_t)
+CPPFLAGS=$zlib_save_CPPFLAGS
+
+AC_CACHE_CHECK([whether to enable -D_LARGEFILE64_SOURCE], [zlib_cv_use_lfs64], [
+ zlib_cv_use_lfs64=no
+ if test "$ac_cv_type_off64_t" = "yes"; then
+ zlib_cv_use_lfs64=yes
+ fi
+])
+
+if test "$zlib_cv_use_lfs64" = "yes"; then
+ CPPFLAGS="$CPPFLAGS -D_LARGEFILE64_SOURCE"
+
+ #APR_ADDTO(CPPFLAGS, [-D_LARGEFILE64_SOURCE])
+fi
+
+cat > zlibdefs.h << EOF
+/* zlibdefs.h -- compile-time definitions for the zlib compression library
+ * Copyright (C) 1995-2006 Jean-loup Gailly.
+ * For conditions of distribution and use, see copyright notice in zlib.h
+ */
+
+#include <sys/types.h> /* for off_t */
+#include <unistd.h> /* for SEEK_* and off_t */
+#ifdef VMS
+# include <unixio.h> /* for off_t */
+#endif
+#ifndef z_off_t
+# define z_off_t off_t
+#endif
+EOF
+
+AC_CONFIG_FILES([Makefile])
+
+AC_OUTPUT
diff --git a/meta/recipes-core/zlib/zlib_1.2.5.bb b/meta/recipes-core/zlib/zlib_1.2.5.bb
new file mode 100644
index 0000000000..e6db69e3a6
--- /dev/null
+++ b/meta/recipes-core/zlib/zlib_1.2.5.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Zlib Compression Library"
+HOMEPAGE = "http://zlib.net/"
+SECTION = "libs"
+PRIORITY = "required"
+LICENSE = "zlib"
+LIC_FILES_CHKSUM = "file://zlib.h;beginline=4;endline=23;md5=084e9c30e4e6272c3b057b13c6467f3d"
+
+DEPENDS = "libtool-cross"
+PR = "r0"
+
+SRC_URI = "http://www.zlib.net/${BPN}-${PV}.tar.bz2 \
+ file://configure.ac \
+ file://Makefile.am"
+
+inherit autotools
+
+do_configure_prepend () {
+ cp ${WORKDIR}/configure.ac ${S}/
+ cp ${WORKDIR}/Makefile.am ${S}/
+}
+
+BBCLASSEXTEND = "native nativesdk"