summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/uclibc
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-07-18 15:39:39 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-20 15:25:01 +0100
commitc480def3a3531577659a9cc0f10640f3df047bc2 (patch)
tree09821578762518d62addeed19484eaae8025a566 /meta/recipes-core/uclibc
parentfea90adb2ad93b1b9dd4c9259b738bbecdce4524 (diff)
downloadopenembedded-core-c480def3a3531577659a9cc0f10640f3df047bc2.tar.gz
uclibc_0.9.32: Implement sync_file_range2.
On some arches e.g. arm, ppc sync_file_range2 is used instead of sync_file_range so we should consider that Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-core/uclibc')
-rw-r--r--meta/recipes-core/uclibc/uclibc-0.9.32/sync_file_range2.patch40
-rw-r--r--meta/recipes-core/uclibc/uclibc_0.9.32.bb3
2 files changed, 42 insertions, 1 deletions
diff --git a/meta/recipes-core/uclibc/uclibc-0.9.32/sync_file_range2.patch b/meta/recipes-core/uclibc/uclibc-0.9.32/sync_file_range2.patch
new file mode 100644
index 0000000000..b5e972edd5
--- /dev/null
+++ b/meta/recipes-core/uclibc/uclibc-0.9.32/sync_file_range2.patch
@@ -0,0 +1,40 @@
+Index: git/libc/sysdeps/linux/common/sync_file_range.c
+===================================================================
+--- git.orig/libc/sysdeps/linux/common/sync_file_range.c 2011-07-19 14:23:35.000000000 -0700
++++ git/libc/sysdeps/linux/common/sync_file_range.c 2011-07-19 15:04:38.631808666 -0700
+@@ -11,7 +11,8 @@
+ #if defined __USE_GNU
+ #include <fcntl.h>
+
+-#if defined __NR_sync_file_range && defined __UCLIBC_HAS_LFS__
++#if defined __UCLIBC_HAS_LFS__
++#if defined __NR_sync_file_range
+ #define __NR___syscall_sync_file_range __NR_sync_file_range
+ static __inline__ _syscall6(int, __syscall_sync_file_range, int, fd,
+ off_t, offset_hi, off_t, offset_lo,
+@@ -23,5 +24,23 @@
+ __LONG_LONG_PAIR((long)(nbytes >> 32), (long)(nbytes & 0xffffffff)),
+ flags);
+ }
+-#endif
+-#endif
++#elif defined __NR_sync_file_range2
++#define __NR___syscall_sync_file_range2 __NR_sync_file_range2
++static __inline__ _syscall6(int, __syscall_sync_file_range2, int, fd,
++ unsigned int, flags, off_t, offset_hi, off_t, offset_lo,
++ off_t, nbytes_hi, off_t, nbytes_lo)
++int sync_file_range(int fd, off64_t offset, off64_t nbytes, unsigned int flags)
++{
++ return __syscall_sync_file_range2(fd, flags,
++ __LONG_LONG_PAIR((long)(offset >> 32), (long)(offset & 0xffffffff)),
++ __LONG_LONG_PAIR((long)(nbytes >> 32), (long)(nbytes & 0xffffffff)));
++}
++#else
++int sync_file_range(int fd, off64_t offset, off64_t nbytes, unsigned int flags)
++{
++ __set_errno (ENOSYS);
++ return -1
++}
++#endif /* __NR_sync_file_range */
++#endif /* __UCLIBC_HAS_LFS__ */
++#endif /* __USE_GNU */
diff --git a/meta/recipes-core/uclibc/uclibc_0.9.32.bb b/meta/recipes-core/uclibc/uclibc_0.9.32.bb
index b9592796f3..8dcb2605eb 100644
--- a/meta/recipes-core/uclibc/uclibc_0.9.32.bb
+++ b/meta/recipes-core/uclibc/uclibc_0.9.32.bb
@@ -1,7 +1,7 @@
SRCREV="9152c4d67c763fde5712e2d181d92c0d7e1e2ab9"
require uclibc.inc
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
PROVIDES += "virtual/${TARGET_PREFIX}libc-for-gcc"
SRC_URI = "git://uclibc.org/uClibc.git;branch=${PV};protocol=git \
@@ -28,5 +28,6 @@ SRC_URI = "git://uclibc.org/uClibc.git;branch=${PV};protocol=git \
file://0001-mips-signalfd.h-SFD_NONBLOCK-for-mips-is-0200-unlike.patch \
file://uclibc-execvpe.patch \
file://uclibc_scheduler_update.patch \
+ file://sync_file_range2.patch \
"
S = "${WORKDIR}/git"