summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/sysvinit
diff options
context:
space:
mode:
authorMatthew McClintock <msm@freescale.com>2012-07-11 18:15:27 -0500
committerSaul Wold <sgw@linux.intel.com>2012-07-16 08:36:57 -0700
commiteecd65f188ba2c924626b7e1bf5c8e2eb51e9b59 (patch)
treea5046fb1303b005e5c75067a763780b0b737d8a5 /meta/recipes-core/sysvinit
parent6612873dc59054e6d37fa7488226218bfb759127 (diff)
downloadopenembedded-core-eecd65f188ba2c924626b7e1bf5c8e2eb51e9b59.tar.gz
sysvinit-inittab_2.88dsf.bb: Allow multiple serial port consoles to be defined
Set SERIAL_CONSOLES if you want to define multiple serial consoles, also if you need to check for the presence of the serial consoles you can also define SERIAL_CONSOLES_CHECK to determine if these are present when you boot. This will prevent error message that pop up when the serial port is not present. SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1 115200;ttyEHV0" SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}" The above lines in machine.conf or elsewhere will have the effect of having two serial consoles and removing any that are not present at boot Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/sysvinit')
-rw-r--r--meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb22
1 files changed, 20 insertions, 2 deletions
diff --git a/meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb b/meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb
index 9bd087cbcb..1089edbcb4 100644
--- a/meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb
+++ b/meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Inittab for sysvinit"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-PR = "r6"
+PR = "r7"
SRC_URI = "file://inittab"
@@ -26,7 +26,8 @@ do_install() {
for i in $tmp
do
j=`echo ${i} | sed s/\;/\ /g`
- echo "${idx}:2345:respawn:${base_sbindir}/getty ${j}" >> ${D}${sysconfdir}/inittab
+ echo "${idx}:12345:respawn:${base_sbindir}/getty ${j}" >> ${D}${sysconfdir}/inittab
+
idx=`expr $idx + 1`
done
@@ -51,6 +52,23 @@ EOF
fi
}
+pkg_postinst_${PN} () {
+# run this on the target
+if [ "x$D" == "x" ]; then
+ tmp="${SERIAL_CONSOLES_CHECK}"
+ for i in $tmp
+ do
+ j=`echo ${i} | sed s/^.*\;//g`
+ if [ -z "`cat /proc/consoles | grep ${j}`" ]; then
+ sed -i /^.*${j}$/d /etc/inittab
+ fi
+ done
+ kill -HUP 1
+else
+ exit 1
+fi
+}
+
# USE_VT and SERIAL_CONSOLE are generally defined by the MACHINE .conf.
# Set PACKAGE_ARCH appropriately.
PACKAGE_ARCH = "${MACHINE_ARCH}"