summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-08-17 09:41:08 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-18 12:35:56 +0100
commite70f843b4fb5ee27d46543165a89d56c2ec5ee2e (patch)
tree7473d697c83b77088e0ad2249aca2fbee059d43b /meta/recipes-core/systemd
parente599c3d75a0e57a798ca360eb55d8661de355ec5 (diff)
downloadopenembedded-core-e70f843b4fb5ee27d46543165a89d56c2ec5ee2e.tar.gz
systemd-boot: Move adjacent to systemd
We always forget to upgrade it when systemd is upgraded, keeping it next to systemd will be an easy reminder to upgrade this recipe along with systemd Define EFI_CC, so far it has been using detection mechanism which worked with gcc but falls back to native gcc when using non-gcc compiler as default system compiler e.g. clang Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/systemd')
-rw-r--r--meta/recipes-core/systemd/systemd-boot_234.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd-boot_234.bb b/meta/recipes-core/systemd/systemd-boot_234.bb
new file mode 100644
index 0000000000..ed55e537eb
--- /dev/null
+++ b/meta/recipes-core/systemd/systemd-boot_234.bb
@@ -0,0 +1,41 @@
+require systemd.inc
+FILESEXTRAPATHS =. "${FILE_DIRNAME}/systemd:"
+
+DEPENDS = "intltool-native libcap util-linux gnu-efi gperf-native"
+
+SRC_URI += "file://0007-use-lnr-wrapper-instead-of-looking-for-relative-opti.patch"
+
+inherit autotools pkgconfig gettext
+inherit deploy
+
+export EFI_CC="${CC}"
+# Man pages are packaged through the main systemd recipe
+EXTRA_OECONF = " --enable-gnuefi \
+ --with-efi-includedir=${STAGING_INCDIR} \
+ --with-efi-ldsdir=${STAGING_LIBDIR} \
+ --with-efi-libdir=${STAGING_LIBDIR} \
+ --disable-manpages \
+ "
+
+# Imported from the old gummiboot recipe
+TUNE_CCARGS_remove = "-mfpmath=sse"
+COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux"
+
+do_compile() {
+ SYSTEMD_BOOT_EFI_ARCH="ia32"
+ if [ "${TARGET_ARCH}" = "x86_64" ]; then
+ SYSTEMD_BOOT_EFI_ARCH="x64"
+ fi
+
+ oe_runmake systemd-boot${SYSTEMD_BOOT_EFI_ARCH}.efi
+}
+
+do_install() {
+ # Bypass systemd installation with a NOP
+ :
+}
+
+do_deploy () {
+ install ${B}/systemd-boot*.efi ${DEPLOYDIR}
+}
+addtask deploy before do_build after do_compile