summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-05-06 18:18:50 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-08 12:12:30 +0100
commit59f93503dcec4e5b8ab46db73095d2669aba8c7e (patch)
treeb828ff9bf9081db1a3eb8549da093bfd9971f053 /meta/recipes-core/systemd
parent2996640fb3577a3c28a22f1e25eae15e8e3d46b1 (diff)
downloadopenembedded-core-59f93503dcec4e5b8ab46db73095d2669aba8c7e.tar.gz
systemd: Add -Wno-error=format-overflow to fix build with gcc9
gcc9 throws additional warnings about format string overflow Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/systemd')
-rw-r--r--meta/recipes-core/systemd/systemd_242.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd_242.bb b/meta/recipes-core/systemd/systemd_242.bb
index a6b39d57e8..69b1f7ed0e 100644
--- a/meta/recipes-core/systemd/systemd_242.bb
+++ b/meta/recipes-core/systemd/systemd_242.bb
@@ -204,6 +204,8 @@ EXTRA_OEMESON += "-Dkexec-path=${sbindir}/kexec \
-Dsulogin-path=${base_sbindir}/sulogin \
-Dumount-path=${base_bindir}/umount"
+CFLAGS += "-Wno-error=format-overflow"
+
do_install() {
meson_do_install
install -d ${D}/${base_sbindir}