aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/packagegroups/packagegroup-go-sdk-target.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2017-09-14 16:22:31 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-09-21 09:03:33 +0100
commit8e16694b2f4c4038c56226821699d0d21578bdf0 (patch)
treedcdc8e42dd634c4fac0b57c2fcb37a6e27020ba1 /meta/recipes-core/packagegroups/packagegroup-go-sdk-target.bb
parent5de3de12c70f01753491c46b5622b0d273c3257b (diff)
downloadopenembedded-core-8e16694b2f4c4038c56226821699d0d21578bdf0.tar.gz
Add Go toolchain support
This adds the meta-go-toolchain. It enables the generation of a Go toolchain allowing for cross compiling for target architecture. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-core/packagegroups/packagegroup-go-sdk-target.bb')
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-go-sdk-target.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta/recipes-core/packagegroups/packagegroup-go-sdk-target.bb b/meta/recipes-core/packagegroups/packagegroup-go-sdk-target.bb
new file mode 100644
index 0000000000..c6c14f1249
--- /dev/null
+++ b/meta/recipes-core/packagegroups/packagegroup-go-sdk-target.bb
@@ -0,0 +1,8 @@
+SUMMARY = "Target packages for the Go SDK"
+
+inherit packagegroup
+
+RDEPENDS_${PN} = " \
+ go-runtime \
+ go-runtime-dev \
+"