summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/musl
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-08-11 15:12:08 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-16 00:01:41 +0100
commit3b4182968c5a1271748002f0e0264f54643a9f1c (patch)
treefbdb0368986db1e1c5905454023dbc098d77d3b1 /meta/recipes-core/musl
parent084eb341281e396b25805bc88b0f09c03112c144 (diff)
downloadopenembedded-core-3b4182968c5a1271748002f0e0264f54643a9f1c.tar.gz
musl: Build only in ARM mode when using clang
clang 5.0 has a codegen bug when compiling musl in thumb2 mode see https://bugs.llvm.org/show_bug.cgi?id=34165 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/musl')
-rw-r--r--meta/recipes-core/musl/musl_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-core/musl/musl_git.bb b/meta/recipes-core/musl/musl_git.bb
index 64c7334eea..eefd23bb8e 100644
--- a/meta/recipes-core/musl/musl_git.bb
+++ b/meta/recipes-core/musl/musl_git.bb
@@ -28,6 +28,8 @@ export CROSS_COMPILE="${TARGET_PREFIX}"
LDFLAGS += "-Wl,-soname,libc.so"
+ARM_INSTRUCTION_SET_toolchain-clang = "arm"
+
CONFIGUREOPTS = " \
--prefix=${prefix} \
--exec-prefix=${exec_prefix} \