summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2012-02-06 14:01:07 -0600
committerSaul Wold <sgw@linux.intel.com>2012-02-09 23:03:20 -0800
commit9c44bb6434a1d2347ebbb38bde9671688b0ae447 (patch)
tree01505faf37779153ec69ff54a9d024390dfde2d8 /meta/recipes-core/meta
parent4ef5e70f531f48cef90805402c16ec02ad3f2b92 (diff)
downloadopenembedded-core-9c44bb6434a1d2347ebbb38bde9671688b0ae447.tar.gz
external-csl-toolchain: fix mtd-user.h issue
The use of __packed, which isn't defined in userspace, caused busybox build failures. Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Diffstat (limited to 'meta/recipes-core/meta')
-rw-r--r--meta/recipes-core/meta/external-csl-toolchain.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/external-csl-toolchain.bb b/meta/recipes-core/meta/external-csl-toolchain.bb
index 22aa99657f..d15578bf78 100644
--- a/meta/recipes-core/meta/external-csl-toolchain.bb
+++ b/meta/recipes-core/meta/external-csl-toolchain.bb
@@ -66,6 +66,7 @@ do_install() {
fi
ln -s ../../bin/gdbserver ${D}${libdir}/bin/sysroot-gdbserver
+ sed -i -e 's/__packed/__attribute__ ((packed))/' ${D}${includedir}/mtd/ubi-user.h
sed -i -e "s# /lib# ../../lib#g" -e "s# /usr/lib# .#g" ${D}${libdir}/libc.so
sed -i -e "s# /lib# ../../lib#g" -e "s# /usr/lib# .#g" ${D}${libdir}/libpthread.so
}