aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/libxml/libxml2.inc
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-05-25 09:15:39 +0000
committerScott Garman <scott.a.garman@intel.com>2012-11-30 14:50:15 -0800
commit54d27bbc26d1e45e51ee8ef0f051a2bd8f627cc0 (patch)
tree383656b6805318a343e2d4f2d42324e38b573def /meta/recipes-core/libxml/libxml2.inc
parentdd1b77c473ee92608ad0a5bdbea0880d2f613c2c (diff)
downloadopenembedded-core-54d27bbc26d1e45e51ee8ef0f051a2bd8f627cc0.tar.gz
libxml2/libxslt: Don't depend on ansidecl.h header
We don't DEPEND on binutils for ansidecl.h so ensure we should never use the header. This makes builds determinstic and means something like: bitbake binutils bitbake libxml2 -c configure bitbake binutils -c clean bitbake libxml2 doen't fail to build. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/libxml/libxml2.inc')
-rw-r--r--meta/recipes-core/libxml/libxml2.inc5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-core/libxml/libxml2.inc b/meta/recipes-core/libxml/libxml2.inc
index 2eecbd30e7..32d6e8cd31 100644
--- a/meta/recipes-core/libxml/libxml2.inc
+++ b/meta/recipes-core/libxml/libxml2.inc
@@ -18,6 +18,11 @@ SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz \
inherit autotools pkgconfig binconfig
+# We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header
+do_configure_prepend () {
+ sed -i -e '/.*ansidecl.h.*/d' ${S}/configure.in
+}
+
EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-catalog --without-docbook --with-c14n"
EXTRA_OECONF_virtclass-native = "--with-python=${STAGING_BINDIR}/python --without-legacy --with-catalog --without-docbook --with-c14n"
EXTRA_OECONF_virtclass-nativesdk = "--with-python=${STAGING_BINDIR}/python --without-legacy --with-catalog --without-docbook --with-c14n"