summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/libxcrypt/libxcrypt_4.4.8.bb
diff options
context:
space:
mode:
authorOleksandr Kravchuk <open.source@oleksandr-kravchuk.com>2019-09-05 17:38:01 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-09-07 07:47:14 +0100
commit06eb03ad1c0357731496531b290a0a2fdfd10f48 (patch)
treebb7ca61a951f51c680ca733a3d504201559c410b /meta/recipes-core/libxcrypt/libxcrypt_4.4.8.bb
parent703e3faaec8c5a22fe3bc9a2a040c960862136c7 (diff)
downloadopenembedded-core-06eb03ad1c0357731496531b290a0a2fdfd10f48.tar.gz
libxcrypt: update to 4.4.8
LICENSE file checksum changed because few contributors were mentioned (see @edbdbbc50beced9c723e7405334583c60a702796). Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/libxcrypt/libxcrypt_4.4.8.bb')
-rw-r--r--meta/recipes-core/libxcrypt/libxcrypt_4.4.8.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-core/libxcrypt/libxcrypt_4.4.8.bb b/meta/recipes-core/libxcrypt/libxcrypt_4.4.8.bb
new file mode 100644
index 0000000000..1787f6921e
--- /dev/null
+++ b/meta/recipes-core/libxcrypt/libxcrypt_4.4.8.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Extended cryptographic library (from glibc)"
+DESCRIPTION = "Forked code from glibc libary to extract only crypto part."
+HOMEPAGE = "https://github.com/besser82/libxcrypt"
+SECTION = "libs"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM ?= "file://LICENSING;md5=3bb6614cf5880cbf1b9dbd9e3d145e2c \
+ file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
+"
+
+inherit autotools pkgconfig
+
+SRC_URI = "git://github.com/besser82/libxcrypt.git;branch=${SRCBRANCH}"
+SRCREV = "acd84997a5a8b2badd28b70a642abee11272fad2"
+SRCBRANCH ?= "develop"
+
+PROVIDES = "virtual/crypt"
+
+FILES_${PN} = "${libdir}/libcrypt*.so.* \
+ ${libdir}/libcrypt-*.so \
+ ${libdir}/libowcrypt*.so.* \
+ ${libdir}/libowcrypt-*.so \
+"
+
+S = "${WORKDIR}/git"
+
+BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
+TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir} -Wno-error"
+CPPFLAGS_append_class-nativesdk = " -Wno-error"
+
+API = "--disable-obsolete-api"
+EXTRA_OECONF += "${API}"
+
+BBCLASSEXTEND = "nativesdk"