aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/images
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2014-02-26 18:21:02 +0200
committerSaul Wold <sgw@linux.intel.com>2014-02-28 11:32:11 +0200
commitabf40223d1412ee8f9d2b5269fad7c6aca6c2570 (patch)
treee533ec5f4670ec7dcd21c3df598b0fb45526c83d /meta/recipes-core/images
parent8a60d490755c2c3010a87f2616008aee2c9cc966 (diff)
downloadopenembedded-core-abf40223d1412ee8f9d2b5269fad7c6aca6c2570.tar.gz
core-image-minimal-initramfs: Use PACKAGE_INSTALL instead of IMAGE_INSTALL
PACKAGE_INSTALL is set from the IMAGE_INSTALL variable with some additional items, since PACKAGE_INSTALL is intended to be more an internal variable, use it instead of the IMAGE_INSTALL which is recommeded for installing additional packages. This will allow the initramfs recipe to use a fixed set of packages and not be affected by IMAGE_INSTALL. [YOCTO #5791] Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/images')
-rw-r--r--meta/recipes-core/images/core-image-minimal-initramfs.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/images/core-image-minimal-initramfs.bb b/meta/recipes-core/images/core-image-minimal-initramfs.bb
index 46a9dc41c2..1f0fa9580b 100644
--- a/meta/recipes-core/images/core-image-minimal-initramfs.bb
+++ b/meta/recipes-core/images/core-image-minimal-initramfs.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "Small image capable of booting a device. The kernel includes \
the Minimal RAM-based Initial Root Filesystem (initramfs), which finds the \
first 'init' program more efficiently."
-IMAGE_INSTALL = "initramfs-live-boot initramfs-live-install initramfs-live-install-efi busybox udev base-passwd"
+PACKAGE_INSTALL = "initramfs-live-boot initramfs-live-install initramfs-live-install-efi busybox udev base-passwd ${ROOTFS_BOOTSTRAP_INSTALL}"
# Do not pollute the initrd image with rootfs features
IMAGE_FEATURES = ""