aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/images/build-appliance-image.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-11-22 21:37:23 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-11-24 15:12:04 +0000
commit53d3c3caf1894e088ebf10fdf233cdf109b04da6 (patch)
tree8aa0666ad6250a1b22c805ee1b7bc3cdd53da0ca /meta/recipes-core/images/build-appliance-image.bb
parent8df3350d107322380582c807ccc92ea353b543ab (diff)
downloadopenembedded-core-53d3c3caf1894e088ebf10fdf233cdf109b04da6.tar.gz
build-appliance-image: Add explict dependency on do_unpack
The code called by do_rootfs explicitly needs the code obtained during do_unpack. If built from sstate, it might not be present so we ensure it is by adding an explicit dependency. This fixes build failures when building from sstate. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/images/build-appliance-image.bb')
-rw-r--r--meta/recipes-core/images/build-appliance-image.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-core/images/build-appliance-image.bb b/meta/recipes-core/images/build-appliance-image.bb
index 2bcfe8c508..35c6abebec 100644
--- a/meta/recipes-core/images/build-appliance-image.bb
+++ b/meta/recipes-core/images/build-appliance-image.bb
@@ -68,6 +68,8 @@ fakeroot do_populate_poky_src () {
IMAGE_PREPROCESS_COMMAND += "do_populate_poky_src; "
+addtask rootfs after do_unpack
+
python () {
# Ensure we run these usually noexec tasks
d.delVarFlag("do_fetch", "noexec")