summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glib-2.0/glib-2.0
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2011-12-02 12:20:04 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-05 22:44:38 +0000
commit512a28b014786a5585d27dbfc785efd620c1d7d6 (patch)
tree96277d1a03e08ccf60f5efbc478d3253542a1aa9 /meta/recipes-core/glib-2.0/glib-2.0
parent145de26a7415357a08bcdbc0307b5a60e2ad1420 (diff)
downloadopenembedded-core-512a28b014786a5585d27dbfc785efd620c1d7d6.tar.gz
glib-2.0: fix compilatoin with x32 toolchain
Pass along CC & CFLAGS vars so that the tune parameters set get used. This fixes compilation with x32 toolchain. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: H.J. Lu <hjl.tools@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glib-2.0/glib-2.0')
-rw-r--r--meta/recipes-core/glib-2.0/glib-2.0/glib-2.0_fix_for_x32.patch76
1 files changed, 76 insertions, 0 deletions
diff --git a/meta/recipes-core/glib-2.0/glib-2.0/glib-2.0_fix_for_x32.patch b/meta/recipes-core/glib-2.0/glib-2.0/glib-2.0_fix_for_x32.patch
new file mode 100644
index 0000000000..70cbbbe915
--- /dev/null
+++ b/meta/recipes-core/glib-2.0/glib-2.0/glib-2.0_fix_for_x32.patch
@@ -0,0 +1,76 @@
+UpstreamStatus: Pending
+
+Pass CC & CFLAGS vars so that tune parameters get used.
+This fixes compilation with x32 toolchain.
+
+Received this patch from H.J. Lu <hjl.tools@gmail.com>
+Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com> 2011/07/13
+
+Index: glib-2.30.0/glib/Makefile.am
+===================================================================
+--- glib-2.30.0.orig/glib/Makefile.am
++++ glib-2.30.0/glib/Makefile.am
+@@ -359,10 +359,10 @@ INSTALL_PROGS=
+
+ if ENABLE_DTRACE
+ glib_probes.h: glib_probes.d Makefile
+- $(AM_V_GEN) $(DTRACE) -C -h -s $< -o $@.tmp
++ $(AM_V_GEN) CFLAGS="$(CFLAGS)" $(DTRACE) -C -h -s $< -o $@.tmp
+ @$(SED) -e "s,define STAP_HAS_SEMAPHORES 1,undef STAP_HAS_SEMAPHORES," < $@.tmp > $@ && rm -f $@.tmp
+ glib_probes.o: glib_probes.d Makefile
+- $(AM_V_GEN) $(DTRACE) -G -s $< -o $@
++ $(AM_V_GEN) CFLAGS="$(CFLAGS)" $(DTRACE) -G -s $< -o $@
+ BUILT_SOURCES += glib_probes.h glib_probes.o
+ CLEANFILES += glib_probes.h glib_probes.h.tmp
+ libglib_2_0_la_LIBADD += glib_probes.o
+Index: glib-2.30.0/glib/Makefile.in
+===================================================================
+--- glib-2.30.0.orig/glib/Makefile.in
++++ glib-2.30.0/glib/Makefile.in
+@@ -1691,10 +1691,10 @@ uninstall-local: uninstall-ms-lib uninst
+ @OS_WIN32_AND_DLL_COMPILATION_FALSE@uninstall-def-file:
+
+ @ENABLE_DTRACE_TRUE@glib_probes.h: glib_probes.d Makefile
+-@ENABLE_DTRACE_TRUE@ $(AM_V_GEN) $(DTRACE) -C -h -s $< -o $@.tmp
++@ENABLE_DTRACE_TRUE@ $(AM_V_GEN) CC="$(CC)" CFLAGS="$(CFLAGS)" $(DTRACE) -C -h -s $< -o $@.tmp
+ @ENABLE_DTRACE_TRUE@ @$(SED) -e "s,define STAP_HAS_SEMAPHORES 1,undef STAP_HAS_SEMAPHORES," < $@.tmp > $@ && rm -f $@.tmp
+ @ENABLE_DTRACE_TRUE@glib_probes.o: glib_probes.d Makefile
+-@ENABLE_DTRACE_TRUE@ $(AM_V_GEN) $(DTRACE) -G -s $< -o $@
++@ENABLE_DTRACE_TRUE@ $(AM_V_GEN) CC="$(CC)" CFLAGS="$(CFLAGS)" $(DTRACE) -G -s $< -o $@
+
+ gspawn-win32-helper-console.c:
+ echo '#define HELPER_CONSOLE' >$@
+Index: glib-2.30.0/gobject/Makefile.am
+===================================================================
+--- glib-2.30.0.orig/gobject/Makefile.am
++++ glib-2.30.0/gobject/Makefile.am
+@@ -141,10 +141,10 @@ gobject_c_sources = \
+
+ if ENABLE_DTRACE
+ gobject_probes.h: gobject_probes.d Makefile
+- $(AM_V_GEN) $(DTRACE) -C -h -s $< -o $@.tmp
++ $(AM_V_GEN) CFLAGS="$(CFLAGS)" $(DTRACE) -C -h -s $< -o $@.tmp
+ @$(SED) -e "s,define STAP_HAS_SEMAPHORES 1,undef STAP_HAS_SEMAPHORES," < $@.tmp > $@ && rm -f $@.tmp
+ gobject_probes.o: gobject_probes.d Makefile
+- $(AM_V_GEN) $(DTRACE) -G -s $< -o $@
++ $(AM_V_GEN) CFLAGS="$(CFLAGS)" $(DTRACE) -G -s $< -o $@
+ BUILT_SOURCES += gobject_probes.h gobject_probes.o
+ CLEANFILES += gobject_probes.h
+ libgobject_2_0_la_LIBADD += gobject_probes.o
+Index: glib-2.30.0/gobject/Makefile.in
+===================================================================
+--- glib-2.30.0.orig/gobject/Makefile.in
++++ glib-2.30.0/gobject/Makefile.in
+@@ -1581,10 +1581,10 @@ uninstall-ms-lib:
+ @OS_WIN32_AND_DLL_COMPILATION_FALSE@uninstall-def-file:
+
+ @ENABLE_DTRACE_TRUE@gobject_probes.h: gobject_probes.d Makefile
+-@ENABLE_DTRACE_TRUE@ $(AM_V_GEN) $(DTRACE) -C -h -s $< -o $@.tmp
++@ENABLE_DTRACE_TRUE@ $(AM_V_GEN) CFLAGS="$(CFLAGS)" $(DTRACE) -C -h -s $< -o $@.tmp
+ @ENABLE_DTRACE_TRUE@ @$(SED) -e "s,define STAP_HAS_SEMAPHORES 1,undef STAP_HAS_SEMAPHORES," < $@.tmp > $@ && rm -f $@.tmp
+ @ENABLE_DTRACE_TRUE@gobject_probes.o: gobject_probes.d Makefile
+-@ENABLE_DTRACE_TRUE@ $(AM_V_GEN) $(DTRACE) -G -s $< -o $@
++@ENABLE_DTRACE_TRUE@ $(AM_V_GEN) CFLAGS="$(CFLAGS)" $(DTRACE) -G -s $< -o $@
+
+ # This is read by gobject-introspection/misc/ and gtk-doc
+ gobject-public-headers.txt: Makefile