summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/expat
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/recipes-core/expat
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadopenembedded-core-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/expat')
-rw-r--r--meta/recipes-core/expat/expat-2.0.1/autotools.patch17
-rw-r--r--meta/recipes-core/expat/expat.inc19
-rw-r--r--meta/recipes-core/expat/expat_2.0.1.bb3
3 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-core/expat/expat-2.0.1/autotools.patch b/meta/recipes-core/expat/expat-2.0.1/autotools.patch
new file mode 100644
index 0000000000..ff1578f47e
--- /dev/null
+++ b/meta/recipes-core/expat/expat-2.0.1/autotools.patch
@@ -0,0 +1,17 @@
+# avoid to use expat's own *.m4
+#
+# comment added by Kevin Tian <kevin.tian@intel.com>, 2010-07-07
+
+diff -bur expat-2.0.0~orig/configure.in expat-2.0.0/configure.in
+--- expat-2.0.0~orig/configure.in 2006-01-10 19:10:46.000000000 -0600
++++ expat-2.0.0/configure.in 2006-02-10 19:12:24.000000000 -0600
+@@ -50,9 +50,6 @@
+
+ AC_CONFIG_HEADER(expat_config.h)
+
+-sinclude(conftools/libtool.m4)
+-sinclude(conftools/ac_c_bigendian_cross.m4)
+-
+ AC_LIBTOOL_WIN32_DLL
+ AC_PROG_LIBTOOL
+
diff --git a/meta/recipes-core/expat/expat.inc b/meta/recipes-core/expat/expat.inc
new file mode 100644
index 0000000000..8c5010e481
--- /dev/null
+++ b/meta/recipes-core/expat/expat.inc
@@ -0,0 +1,19 @@
+DESCRIPTION = "Expat is an XML parser library written in C. It is a stream-oriented parser in which an application registers handlers for things the parser might find in the XML document (like start tags)"
+HOMEPAGE = "http://expat.sourceforge.net/"
+SECTION = "libs"
+LICENSE = "MIT"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/expat/expat-${PV}.tar.gz \
+ file://autotools.patch"
+
+inherit autotools lib_package
+
+# This package uses an archive format known to have issue with some
+# versions of gzip
+do_unpack[depends] += "gzip-native:do_populate_sysroot"
+
+do_configure_prepend () {
+ rm -f ${S}/conftools/libtool.m4
+}
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-core/expat/expat_2.0.1.bb b/meta/recipes-core/expat/expat_2.0.1.bb
new file mode 100644
index 0000000000..9983fe5838
--- /dev/null
+++ b/meta/recipes-core/expat/expat_2.0.1.bb
@@ -0,0 +1,3 @@
+require expat.inc
+
+PR = "r0"