summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei@gherzan.ro>2013-08-23 17:20:58 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-23 16:04:49 +0100
commiteacf0f3ed15eccb52eb6b98e20b75f0aa26b6e81 (patch)
tree1f856fc0d67552f2b62120a73ce99113cf3df3d1 /meta/recipes-core/eglibc
parent6f07d066074b1e01ff3c16408812e6b6d5e531ac (diff)
downloadopenembedded-core-eacf0f3ed15eccb52eb6b98e20b75f0aa26b6e81.tar.gz
eglibc.inc: Remove quotation marks from OPTION_EGLIBC_NSSWITCH_FIXED_*
Kconfig outputs strings with quotation marks. When eglibc tries to see if the paths exists, uses wildcard make function which doesn't strip out the quotation marks - checking for path fails. So strip out the quotation marks from OPTION_EGLIBC_NSSWITCH_FIXED_* option-groups.config. (see nss/Makefile) Signed-off-by: Andrei Gherzan <andrei.gherzan@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/eglibc')
-rw-r--r--meta/recipes-core/eglibc/eglibc.inc4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-core/eglibc/eglibc.inc b/meta/recipes-core/eglibc/eglibc.inc
index 40dd6b5847..375b9bc116 100644
--- a/meta/recipes-core/eglibc/eglibc.inc
+++ b/meta/recipes-core/eglibc/eglibc.inc
@@ -75,6 +75,10 @@ do_configure_prepend() {
do_configure_append() {
oe_runmake config
+
+ # Remove quotation marks from OPTION_EGLIBC_NSSWITCH_FIXED_*. This will
+ # avoid install error.
+ sed -i 's/^OPTION_EGLIBC_NSSWITCH_FIXED_\(.*\)="\(.*\)"$/OPTION_EGLIBC_NSSWITCH_FIXED_\1=\2/' option-groups.config
}
GLIBC_ADDONS ?= "ports,nptl,libidn"