summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-18 01:13:30 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-18 13:17:38 +0000
commit68f447c46596387f95072743926298fc64cdd3b9 (patch)
tree3529bb0ce12177b1d5a487052309dd582c3b569a /meta/recipes-core/eglibc
parentf235a69f8d5cee6f6d8e7feccd83e8e619e2ddcf (diff)
downloadopenembedded-core-68f447c46596387f95072743926298fc64cdd3b9.tar.gz
cross-localedef-native: Fix case where ${B} != ${S}
This change allows ${B} != ${S} builds to work since otherwise configure isn't found. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/eglibc')
-rw-r--r--meta/recipes-core/eglibc/cross-localedef-native_2.17.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-core/eglibc/cross-localedef-native_2.17.bb b/meta/recipes-core/eglibc/cross-localedef-native_2.17.bb
index 0fedfad641..1d3c22bf57 100644
--- a/meta/recipes-core/eglibc/cross-localedef-native_2.17.bb
+++ b/meta/recipes-core/eglibc/cross-localedef-native_2.17.bb
@@ -39,11 +39,11 @@ EXTRA_OECONF = "--with-glibc=${WORKDIR}/eglibc-${PV}/libc"
CFLAGS += "-DNOT_IN_libc=1"
do_configure () {
- ./configure ${EXTRA_OECONF}
+ ${S}/configure ${EXTRA_OECONF}
}
do_install() {
install -d ${D}${bindir}
- install -m 0755 ${S}/localedef ${D}${bindir}/cross-localedef
+ install -m 0755 ${B}/localedef ${D}${bindir}/cross-localedef
}