aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-10-17 14:59:43 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-10-22 14:57:26 +0100
commit77ee4d7d88976c7bb2bb25b57e06b83edaacbd4c (patch)
tree61fab6cbcd7c80f2d6efc5322a898390503de640 /meta/recipes-core/eglibc
parent74b5f8943b2b29c7b3b62be7d81fb2b3a86b9584 (diff)
downloadopenembedded-core-77ee4d7d88976c7bb2bb25b57e06b83edaacbd4c.tar.gz
eglibc-2.16: Use tar ball instead of svn SRC_URI
Adapt the recipes to fetch a tarball. Tarball is generated from latest 2.16 branch which has e500-math_private.patch already applied hence we remove that patch. Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/eglibc')
-rw-r--r--meta/recipes-core/eglibc/cross-localedef-native_2.16.bb20
-rw-r--r--meta/recipes-core/eglibc/eglibc-2.16/e500-math_private.patch31
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.16.bb19
3 files changed, 20 insertions, 50 deletions
diff --git a/meta/recipes-core/eglibc/cross-localedef-native_2.16.bb b/meta/recipes-core/eglibc/cross-localedef-native_2.16.bb
index a79a276ae4..11970e70c0 100644
--- a/meta/recipes-core/eglibc/cross-localedef-native_2.16.bb
+++ b/meta/recipes-core/eglibc/cross-localedef-native_2.16.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.eglibc.org/home"
SECTION = "libs"
LICENSE = "LGPL-2.1"
-LIC_DIR = "${WORKDIR}/${EGLIBC_BRANCH}/libc"
+LIC_DIR = "${WORKDIR}/eglibc-${PV}/libc"
LIC_FILES_CHKSUM = "file://${LIC_DIR}/LICENSES;md5=98a1128c4b58120182cbea3b1752d8b9\
file://${LIC_DIR}/COPYING;md5=393a5ca445f6965873eca0259a17f833 \
file://${LIC_DIR}/posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
@@ -16,26 +16,28 @@ inherit autotools
# pick up an eglibc-2.16 patch
FILESPATH = "${FILE_DIRNAME}/eglibc-${PV}"
-PR = "r1"
-SRCREV="19383"
-EGLIBC_BRANCH="eglibc-2_16"
-SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};protocol=http \
+PR = "r2"
+SRC_URI = "http://downloads.yoctoproject.org/releases/eglibc/eglibc-${PV}-svnr21224.tar.bz2 \
file://fix_for_centos_5.8.patch;patchdir=.. \
"
-S = "${WORKDIR}/${EGLIBC_BRANCH}/localedef"
+
+SRC_URI[md5sum] = "88894fa6e10e58e85fbd8134b8e486a8"
+SRC_URI[sha256sum] = "460a45f422da6eb1fd909baab6a64b5ae4c8ba18ea05a1491ed1024c8b98eeaa"
+
+S = "${WORKDIR}/eglibc-${PV}/localedef"
do_unpack_append() {
bb.build.exec_func('do_move_ports', d)
}
do_move_ports() {
- if test -d ${WORKDIR}/${EGLIBC_BRANCH}/ports ; then
+ if test -d ${WORKDIR}/eglibc-${PV}/ports ; then
rm -rf ${WORKDIR}/libc/ports
- mv ${WORKDIR}/${EGLIBC_BRANCH}/ports ${WORKDIR}/libc/
+ mv ${WORKDIR}/eglibc-${PV}/ports ${WORKDIR}/libc/
fi
}
-EXTRA_OECONF = "--with-glibc=${WORKDIR}/${EGLIBC_BRANCH}/libc"
+EXTRA_OECONF = "--with-glibc=${WORKDIR}/eglibc-${PV}/libc"
CFLAGS += "-DNOT_IN_libc=1"
do_configure () {
diff --git a/meta/recipes-core/eglibc/eglibc-2.16/e500-math_private.patch b/meta/recipes-core/eglibc/eglibc-2.16/e500-math_private.patch
deleted file mode 100644
index 9dbb26e1e4..0000000000
--- a/meta/recipes-core/eglibc/eglibc-2.16/e500-math_private.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-Match with the latest math_private restructuring in glibc
-
-as done here
-
-http://sourceware.org/ml/libc-alpha/2012-03/msg00302.html
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-
-Upstream-Status: Pending
-
-Index: libc/ports/sysdeps/powerpc/powerpc32/e500/fpu/math_private.h
-===================================================================
---- libc.orig/ports/sysdeps/powerpc/powerpc32/e500/fpu/math_private.h 2012-07-17 22:58:20.340405923 -0700
-+++ libc/ports/sysdeps/powerpc/powerpc32/e500/fpu/math_private.h 2012-07-17 22:58:21.120405923 -0700
-@@ -1 +1 @@
--#include <math/math_private.h>
-+#include_next <sysdeps/generic/math_private.h>
-Index: libc/ports/sysdeps/powerpc/powerpc32/e500/fpu/fraiseexcpt.c
-===================================================================
---- libc.orig/ports/sysdeps/powerpc/powerpc32/e500/fpu/fraiseexcpt.c 2012-07-17 23:15:15.872405939 -0700
-+++ libc/ports/sysdeps/powerpc/powerpc32/e500/fpu/fraiseexcpt.c 2012-07-17 23:18:42.760405602 -0700
-@@ -23,7 +23,7 @@
-
- #undef feraiseexcept
-
--#define __FERAISEEXCEPT_INTERNAL feraiseexcept
-+#define __FERAISEEXCEPT_INTERNAL __feraiseexcept
- #include "../spe-raise.c"
-
--libm_hidden_def (feraiseexcept)
-+libm_hidden_ver (__feraiseexcept, feraiseexcept)
diff --git a/meta/recipes-core/eglibc/eglibc_2.16.bb b/meta/recipes-core/eglibc/eglibc_2.16.bb
index 2c1018f21c..56a0a38192 100644
--- a/meta/recipes-core/eglibc/eglibc_2.16.bb
+++ b/meta/recipes-core/eglibc/eglibc_2.16.bb
@@ -1,13 +1,9 @@
require eglibc.inc
-SRCREV = "20393"
-
DEPENDS += "gperf-native kconfig-frontends-native"
-PR = "r16"
-PR_append = "+svnr${SRCPV}"
+PR = "r17"
-EGLIBC_BRANCH="eglibc-2_16"
-SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};protocol=http \
+SRC_URI = "http://downloads.yoctoproject.org/releases/eglibc/eglibc-${PV}-svnr21224.tar.bz2 \
file://eglibc-svn-arm-lowlevellock-include-tls.patch \
file://IO-acquire-lock-fix.patch \
file://mips-rld-map-check.patch \
@@ -21,7 +17,6 @@ SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};protocol=h
file://initgroups_keys.patch \
file://eglibc_fix_findidx_parameters.patch \
file://ppc_slow_ieee754_sqrt.patch \
- file://e500-math_private.patch \
file://fileops-without-wchar-io.patch \
file://add_resource_h_to_wait_h.patch \
file://0001-Avoid-use-of-libgcc_s-and-libgcc_eh-when-building-gl.patch \
@@ -33,6 +28,10 @@ SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};protocol=h
file://fsl-ppc-no-fsqrt.patch \
file://0001-R_ARM_TLS_DTPOFF32.patch \
"
+
+SRC_URI[md5sum] = "88894fa6e10e58e85fbd8134b8e486a8"
+SRC_URI[sha256sum] = "460a45f422da6eb1fd909baab6a64b5ae4c8ba18ea05a1491ed1024c8b98eeaa"
+
LIC_FILES_CHKSUM = "file://LICENSES;md5=98a1128c4b58120182cbea3b1752d8b9 \
file://COPYING;md5=393a5ca445f6965873eca0259a17f833 \
file://posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
@@ -41,7 +40,7 @@ LIC_FILES_CHKSUM = "file://LICENSES;md5=98a1128c4b58120182cbea3b1752d8b9 \
SRC_URI_append_virtclass-nativesdk = " file://ld-search-order.patch \
file://relocatable_sdk.patch \
"
-S = "${WORKDIR}/${EGLIBC_BRANCH}/libc"
+S = "${WORKDIR}/eglibc-${PV}/libc"
B = "${WORKDIR}/build-${TARGET_SYS}"
PACKAGES_DYNAMIC = ""
@@ -93,9 +92,9 @@ do_unpack_append() {
}
do_move_ports() {
- if test -d ${WORKDIR}/${EGLIBC_BRANCH}/ports ; then
+ if test -d ${WORKDIR}/eglibc-${PV}/ports ; then
rm -rf ${S}/ports
- mv ${WORKDIR}/${EGLIBC_BRANCH}/ports ${S}/
+ mv ${WORKDIR}/eglibc-${PV}/ports ${S}/
fi
}