summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc/eglibc_2.16.bb
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2012-11-15 13:19:52 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-11-24 15:12:08 +0000
commit9ca1c6120fad5dcae1694e8e37331c1b903f1fd0 (patch)
treea746aacb60b27c87c6b7dc1608e12517e15d87be /meta/recipes-core/eglibc/eglibc_2.16.bb
parent0e97ef30c3819e22f43d88e817e8a8b39ca30e5d (diff)
downloadopenembedded-core-9ca1c6120fad5dcae1694e8e37331c1b903f1fd0.tar.gz
eglibc: always compile with optimization.
eglibc fails to compile if someone tries to compile an entire image as -O0: error "glibc cannot be compiled without optimization" so in this case, force to use -O2 and give a note about it. [YOCTO #3405] Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/eglibc/eglibc_2.16.bb')
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.16.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta/recipes-core/eglibc/eglibc_2.16.bb b/meta/recipes-core/eglibc/eglibc_2.16.bb
index aa9256cdc1..71bcc308b3 100644
--- a/meta/recipes-core/eglibc/eglibc_2.16.bb
+++ b/meta/recipes-core/eglibc/eglibc_2.16.bb
@@ -87,6 +87,17 @@ EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
+# eglibc can't be built without optimization, if someone tries to compile an
+# entire image as -O0, we override it with -O2 here and give a note about it.
+def get_optimization(d):
+ selected_optimization = d.getVar("SELECTED_OPTIMIZATION", True)
+ if base_contains("SELECTED_OPTIMIZATION", "-O0", "x", "", d) == "x":
+ bb.note("eglibc can't be built with -O0, -O2 will be used instead.")
+ return selected_optimization.replace("-O0", "-O2")
+ return selected_optimization
+
+SELECTED_OPTIMIZATION := "${@get_optimization(d)}"
+
do_unpack_append() {
bb.build.exec_func('do_move_ports', d)
}