summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/coreutils
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2017-05-30 10:08:36 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-05 17:59:40 +0100
commit2fcb9bee2487ba8c5e7b2c1fda2fdffcf7fb7f78 (patch)
tree3bc15544349df11e23212f117aafa6b648dbfe51 /meta/recipes-core/coreutils
parentfac6c0fcb30d7cb49036cb32247569d65d1c5e7f (diff)
downloadopenembedded-core-2fcb9bee2487ba8c5e7b2c1fda2fdffcf7fb7f78.tar.gz
recipes: Replace "cp -a" with "cp -R --no-dereference --preserve=mode, links"
* Using "cp -a" leaks UID of user running the builds, causing many QA warnings. * See this thread for details: http://lists.openembedded.org/pipermail/openembedded-core/2015-November/112904.html Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/coreutils')
-rw-r--r--meta/recipes-core/coreutils/coreutils_8.27.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/coreutils/coreutils_8.27.bb b/meta/recipes-core/coreutils/coreutils_8.27.bb
index 667e0af560..ea8740a2d1 100644
--- a/meta/recipes-core/coreutils/coreutils_8.27.bb
+++ b/meta/recipes-core/coreutils/coreutils_8.27.bb
@@ -99,7 +99,7 @@ do_install_append() {
install -t ${D}/${mandir}/man1 ${S}/man/*.1
# prebuilt man pages don't do a separate man page for [ vs test.
# see comment above r.e. sed and update-alternatives
- cp -a ${D}${mandir}/man1/test.1 ${D}${mandir}/man1/lbracket.1.${BPN}
+ cp -R --no-dereference --preserve=mode,links -v ${D}${mandir}/man1/test.1 ${D}${mandir}/man1/lbracket.1.${BPN}
}
inherit update-alternatives